[MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras



  • @bill22
    In the config part add

    rotateStreams: true,
    rotateStreamTimeout: 60,
    

    and add 2 or more streams (stream1 and stream2).



  • Silly question - is there a way within the RTSP protocal to detect when the camera detects motion, so you can trigger something? What I was thinking is to flash the screen background if the camera sees motion…

    Thanks!



  • Is there a way to hide the play/pause button? I’m not using a mouse on my mirror so it’s useless. Also, i’s creating its own separate gigantic white box that doesn’t line up with my actual video stream (which I have to force its position using moduleOffset).



  • The white box is easy to get rid of:

    In ~/MagicMirror/css/custom.css

    /* This removes the white border around the RTSP feed(s). */
    .MMM-RTSPStream .innerWrapper {
      border: 0;
    }
    

    As far as the play button, I’ve never seen it, so I don’t know how to get rid of it, I don’t use keyboard or mouse on my mirror.

    FYI, other css that might be useful:

    /* This shrinks the left and right regions so that RTSPStream don't overlap. */
    .region.right .module-content,
    .region.left .module-content {
      min-width: 450px;
      max-width: 450px;
    }
    

    – B



  • @BKeyport That worked to remove the white box, thanks!

    I’m still struggling with getting the module to just show where I want it. I don’t know why it doesn’t just listen to “position” like every other module where I can tell them all to be top_right and they’d all line up in the appropriate order. I’m fighting with moduleOffset entering random numbers to see if I can find a decent spot, but it still overlaps, causes indentation, and is just a mess. Then often times the module will just disappear after being on screen for a couple minutes.



  • Odd - I’m having no problem moving it around - although, if you’re using OMXPlayer, it’s overlaying on top of the screen, it won’t play nice with other modules in the same position…



  • Hello, I’m Peter,
    when I add RTSTStream to my MagicMirror, I have a little problem with RTSPStream module.

    When display is in normal mode on 27’ screen, everything is ok, picture from Cam is good, normal dimensions etc
    https://photos.app.goo.gl/czoZvwryGmqfJRDg6

    But when in /boot/config.txt in rpi3 the display_rotation=1, picture form cam is cut like on screen.

    https://photos.app.goo.gl/VRycUb7zMw9LQVxh6

    Someone could help me with this problem?

    Many thanks to You All
    Peter



  • @osnapus

    Try using the GL driver to rotate…
    https://github.com/michmich/magicmirror/wiki/configuring-the-raspberry-pi#enable-the-open-gl-driver-to-decrease-electrons-cpu-usage

    I’ll post my config.txt and autostart settings tonight, don’t have access to them right now.



  • Is it possible to define a stream for playing a local file (e.g. .mp4 or .avi)?



  • works with

    		{
    			module: "MMM-RTSPStream",
    			position: "middle_center",
    			config: {
    				autoStart			: true,
    				rotateStreams		: false,
    				rotateStreamTimeout	: 30,
    				moduleWidth			: 354,
    				moduleHeight		: 240,
    				localPlayer			: 'omxplayer',
    				shutdownDelay		: 0,
    
    					stream1: {
    						name: 'Test Stream',
    						url: 'file:///home/pi/MagicMirror/modules/MMM-RTSPStream/Videos/Feuer.mp4',
    					},
    				}
    		},
    

    but no sound !

    in bash console works with: omxplayer -o alsa Feuer.mp4
    How to set hdmi sound as default ?