MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Default modules not working after updated to 2.1.2



  • Hi everyone,
    I tried update my MM from 2.1.x and 2.0 to 2.1.2, update process were all good.
    but, after I start MM, date and time show in English, not Chinese, and “calendar_monthly” module also in English. More unexpected is default modules, like “calendar”, “newsfeed” are always display "Loading "

    after check everything, I found it happens when language sets to ‘zh_tw’ (Chinese, zh_cn same)
    when I set language to “en”, everything is fine.

    var config = {
    	port: 8080,
    
    	language: 'en',
    	timeFormat: 24,
    	units: 'metric',
    
    

    Could someone help to do quick check for this? If you change language parameter in config.js to see if newsfeed and calendar not work.
    That will be very appreciate, if someone knows how to fix this problem.

    var config = {
    	port: 8080,
    
    	language: 'zh_tw',
    	timeFormat: 24,
    	units: 'metric',
    

    language: ‘en’, all good but translation.
    1_1504454472436_2017-09-04-000116_1080x1920_scrot.png

    language: ‘zh_tw’, not working for some module.
    0_1504454472435_2017-09-03-235552_1080x1920_scrot.png

    both don’t have warning message when starting MM.

    Is it a bug or something I missed?



  • @iMAGiC calendar_monthly and clock using moment locales to translate, so your language codes are probably not the ones that are supported with moment or should be slightly different. not sure though why the other modules stuck on loading, do you get any errors or debug messages in the electron console?



  • This post is deleted!


  • found problem is on calendar module. when using calendar module, it can cause “date/time” and "calendar monthly "display in English, and newsfeed, calendar are stuck.
    after I try every module, and use MMM-MyCalendar instead, it works.

    0_1504508423909_2017-09-04-145855_1080x1920_scrot.png

    *Post here may help someone who met same problem.



  • Completely unrelated, but how are you getting those lines under the header to be exactly the same length everywhere?



  • @Kimzer at the first I thought same as you, but it happens, that’s why I spent a day to deal with it, you could try just simply change lang to zh or zh_tw, it will stuck, my two builds are the same.



  • @Kimzer for the line, I think it depends on css region 's setting. I have not change something to the line.



  • @Kimzer modules usually share the same width in the same region, so all modules in top_right for example would have the same width