MagicMirror directory missing.



  • OK. I had Jessie running on a Pi3 from China.
    Revision : a22082

    Everything was running fine until I put it away for a couple months and then Jessie did an update and I got the blank screen error. I tried what I could, including rolling back electron etc. but I couldn’t get rid of it.

    So, I saved my config files and kissed a few other node.js goodies I was using goodbye knowing I’d rebuild them better than before. So I installed a fresh image of Stretch and reinstalled MagicMirror. Still no joy so I tried pretty much anything I could think of or find on the net to help but still… blank screen.

    so. I tried again. this time things got actually weird. I ran the install script and it seemed to work but I didn’t have a MagicMirror directory. So I ran the script again and got an error that said I already had an install and to either rename the directory or do a git pull inside the directory.

    alt text

    I’m sort of at an impasse. I can’t find anything to delete to make the script run again and I don’t REALLY want to do a fresh install of stretch.

    Any suggestions?


  • Module Developer

    @dantodd said in MagicMirror directory missing.:

    Any suggestions?

    FYI, Stretch has been problematic for a number of users in various circumstances. With that said, you could try downloading MM manually and moving it into that directory and see what happens, if anything. If it moves normally, and appears, you can run npm install in the new MM directory.

    Edit:

    Try doing the above in your GUI, rather than in your terminal, with the exception of npm install of course.



  • thanks. I’ll give that a shot. Or maybe I’ll see about installing a Jessie image. I just hate using old software due to potential security issues and breaking other, newer apps.



  • Well. After manually installing version 1.7.6 of electron and globally installing the coffee and lint nodes that the initial install complained about. I ran the manual install and everything seems to be working. I now have to add back my modules and see where we are.

    Thanks.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.