npm start doesn't work



  • I hope someone is able to help me. If i type npm start the following error message appears:

    pi@raspberrypi:~/MagicMirror $ npm start
    
    > magicmirror@2.1.3 start /home/pi/MagicMirror
    > sh run-start.sh
    
    run-start.sh: 4: run-start.sh: electron: not found
    
    npm ERR! magicmirror@2.1.3 start: `sh run-start.sh`
    npm ERR! Exit status 127
    npm ERR! 
    npm ERR! Failed at the magicmirror@2.1.3 start script.
    npm ERR! This is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     sh run-start.sh
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    npm ERR! System Linux 4.4.34-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "start"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code ELIFECYCLE
    npm WARN This failure might be due to the use of legacy binary "node"
    npm WARN For further explanations, please read
    /usr/share/doc/nodejs/README.Debian
     
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~/MagicMirror $ 
    

  • Module Developer

    @Tschanz said in npm start doesn’t work:

    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21

    You need to update your node which should also update your npm



  • I have tried :

    $ sudo apt update
    

    and

    $ sudo apt install nodejs
    

    But there is still the same error. I hope somebody can help me.:)