Failed at the magicmirror@2.2.2 start script 'sh-run-start.sh'



  • Hello,
    I just installed magicmirror on a clean Raspberry Pi 3 with raspian OS.
    After installing and trying to start in the MM directory with npm start I will get the error message:

    > magicmirror@2.2.2 start /home/pi/MagicMirror
    > sh run-start.sh
    
    
    npm ERR! Linux 4.9.73-v7+
    npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "start"
    npm ERR! node v6.12.3
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! magicmirror@2.2.2 start: `sh run-start.sh`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.2.2 start script 'sh run-start.sh'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     sh run-start.sh
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs magicmirror
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    pi@raspi_3:~/MagicMirror $ cat npm-debug.log
    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
    2 info using npm@3.10.10
    3 info using node@v6.12.3
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.2.2~prestart: magicmirror@2.2.2
    6 silly lifecycle magicmirror@2.2.2~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.2.2~start: magicmirror@2.2.2
    8 verbose lifecycle magicmirror@2.2.2~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.2.2~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.2.2~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.2.2~start: Args: [ '-c', 'sh run-start.sh' ]
    12 silly lifecycle magicmirror@2.2.2~start: Returned: code: 1  signal: null
    13 info lifecycle magicmirror@2.2.2~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.2.2 start: `sh run-start.sh`
    14 verbose stack Exit status 1
    14 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:255:16)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at EventEmitter.emit (events.js:191:7)
    14 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at ChildProcess.emit (events.js:191:7)
    14 verbose stack     at maybeClose (internal/child_process.js:920:16)
    14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
    15 verbose pkgid magicmirror@2.2.2
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.9.73-v7+
    18 error argv "/usr/bin/node" "/usr/bin/npm" "start"
    19 error node v6.12.3
    20 error npm  v3.10.10
    21 error code ELIFECYCLE
    22 error magicmirror@2.2.2 start: `sh run-start.sh`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.2.2 start script 'sh run-start.sh'.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error     sh run-start.sh
    23 error You can get information on how to open an issue for this project with:
    23 error     npm bugs magicmirror
    23 error Or if that isn't available, you can get their info via:
    23 error     npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    pi@raspi_3:~/MagicMirror $
    

    Tried to update nodejs and npm but they are OK, does anyone had the same problem and knows a workaroud?

    Thank you very much

    Regards,
    Max



  • I guess u are in stretch. I’m on a rpi 3 and i find impossible to start MM. I’ll dpwngrade to Jessie and try again. If It does not work you can always make an HTML page and use chromium fullscreen



  • Well, i am using Raspberry Pi 3 with raspbian stretch lite and it works great.

    what OS are u using?
    Did u use the automatic installer or u did it manually?
    via ssh u have to use: DISPLAY=:0 npm start



  • Install it manually not via the installer…too many issues.



  • I have stretch full (mm owner said lite not supported in a comment in this forum)
    I tried both automatic and manual installation, i tried with both node js 9.3.0 and the automatic node update from MM.
    How you installed It? What node version? Did u use -g after npm install?
    Btw i work only from SSH, to make It start i used pm2 before this new clean install

    I think my installer can’t install electron from what i read at installation fail



  • i did it exactly as wrote in this tutorial:

    https://github.com/MichMich/MagicMirror/wiki/Jessie-Lite-Installation-Guide

    only difference:
    i used Raspbian stretch lite and to disable the screensaver i used xscreensaver

    does need a little bit longer because u need to install the dependancies first, but it runs from the beginning without issues.

    but to be on the safety side, you can use raspbian jesse full as many users wrote about problems with stretch



  • Thank you for your answers.

    I am using stretch, see the cat /etc/os-release

    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="9"
    VERSION="9 (stretch)"
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
    

    I followed the steps in this guide Complete Setup Tutorial

    DISPLAY=:0 npm start can not solve the problem.

    I will try to install MM with the Guide on GitHub you posted and I will see that comes out.
    I will keep you updated.

    EDIT: So I followed the guide on GitHub and it works perfectly.
    Thank you very much for this suggestion.



  • Just tried again following this guide:
    https://github.com/MichMich/MagicMirror/wiki/Jessie-Lite-Installation-Guide
    so:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install xinit xserver-xorg
    sudo apt-get install lxde-core
    sudo apt-get install lightdm
    sudo apt-get install git
    sudo apt-get install libxss1
    sudo apt-get install libnss3
    sudo apt-get install unclutter
    then once it said to use the autoinstaller i went with manual installation.
    After git clone i cd into MM and tried npm install… Ofc i didn’t work cause of missing npm so i tried with the simplest sudo apt-get install npm. After that i tried to verify node version with node -v but it did not gave any response. I tried anyway with sudo npm install into mm folder and it started… after a while it failed. This is the error i got, log attached.
    [0_1515066236979_npm-debug.log](Uploading 100%)

    npm WARN deprecated coffee-script@1.10.0: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
    npm WARN engine webdriverio@4.9.11: wanted: {"node":">= 4.8.5"} (current: {"node":"4.8.2","npm":"1.4.21"})
    
    > electron@1.4.15 postinstall /home/pi/MagicMirror/node_modules/electron
    > node install.js
    
    sh: 1: node: not found
    npm WARN This failure might be due to the use of legacy binary "node"
    npm WARN For further explanations, please read
    /usr/share/doc/nodejs/README.Debian
    
    npm ERR! electron@1.4.15 postinstall: `node install.js`
    npm ERR! Exit status 127
    npm ERR!
    npm ERR! Failed at the electron@1.4.15 postinstall script.
    npm ERR! This is most likely a problem with the electron package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node install.js
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls electron
    npm ERR! There is likely additional logging output above.
    
    npm ERR! System Linux 4.9.59-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v4.8.2
    npm ERR! npm -v 1.4.21
    npm ERR! code ELIFECYCLE
    -
    > uws@0.14.5 install /home/pi/MagicMirror/node_modules/socket.io/node_modules/engine.io/node_modules/uws
    > node-gyp rebuild > build_log.txt 2>&1 || exit 0
    
    
    > electron-chromedriver@1.7.1 install /home/pi/MagicMirror/node_modules/spectron/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    sh: 1: node: not found
    npm WARN This failure might be due to the use of legacy binary "node"
    npm WARN For further explanations, please read
    /usr/share/doc/nodejs/README.Debian
    
    npm ERR! tar.unpack untar error /root/.npm/webdriverio/4.9.11/package.tgz
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    
    


  • @mafin could you give me the exact command lint you used? In that guide the only thing said about the installation is to use the automatic installer…
    Using it i’m stuck here: (is it complete or stuck?)

    pi@raspberrypi:~ $ sudo bash -c "$(curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh)"
    
    $$\      $$\                     $$\           $$\      $$\ $$\                                          $$$$$$\
    $$$\    $$$ |                    \__|          $$$\    $$$ |\__|                                        $$  __$$\
    $$$$\  $$$$ | $$$$$$\   $$$$$$\  $$\  $$$$$$$\ $$$$\  $$$$ |$$\  $$$$$$\   $$$$$$\   $$$$$$\   $$$$$$\  \__/  $$ |
    $$\$$\$$ $$ | \____$$\ $$  __$$\ $$ |$$  _____|$$\$$\$$ $$ |$$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  __$$\  $$$$$$  |
    $$ \$$$  $$ | $$$$$$$ |$$ /  $$ |$$ |$$ /      $$ \$$$  $$ |$$ |$$ |  \__|$$ |  \__|$$ /  $$ |$$ |  \__|$$  ____/
    $$ |\$  /$$ |$$  __$$ |$$ |  $$ |$$ |$$ |      $$ |\$  /$$ |$$ |$$ |      $$ |      $$ |  $$ |$$ |      $$ |
    $$ | \_/ $$ |\$$$$$$$ |\$$$$$$$ |$$ |\$$$$$$$\ $$ | \_/ $$ |$$ |$$ |      $$ |      \$$$$$$  |$$ |      $$$$$$$$\
    \__|     \__| \_______| \____$$ |\__| \_______|\__|     \__|\__|\__|      \__|       \______/ \__|      \________|
                           $$\   $$ |
                           \$$$$$$  |
                            \______/
    
    Updating packages ...
    Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists... Done
    Installing helper tools ...
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    build-essential is already the newest version (12.3).
    curl is already the newest version (7.52.1-5+deb9u3).
    git is already the newest version (1:2.11.0-3+deb9u2).
    unzip is already the newest version (6.0-21).
    wget is already the newest version (1.18-5+deb9u1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Check current Node installation ...
    Node.js is not installed.
    Installing Node.js ...
    
    ## Installing the NodeSource Node.js v6.x repo...
    
    
    ## Populating apt-get cache...
    
    + apt-get update
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Reading package lists... Done
    
    ## Confirming "stretch" is supported...
    
    + curl -sLf -o /dev/null 'https://deb.nodesource.com/node_6.x/dists/stretch/Release'
    
    ## Adding the NodeSource signing key to your keyring...
    
    + curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
    OK
    
    ## Creating apt sources list file for the NodeSource Node.js v6.x repo...
    
    + echo 'deb https://deb.nodesource.com/node_6.x stretch main' > /etc/apt/sources.list.d/nodesource.list
    + echo 'deb-src https://deb.nodesource.com/node_6.x stretch main' >> /etc/apt/sources.list.d/nodesource.list
    
    ## Running `apt-get update` for you...
    
    + apt-get update
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Get:3 https://deb.nodesource.com/node_6.x stretch InRelease [4,635 B]
    Get:4 https://deb.nodesource.com/node_6.x stretch/main armhf Packages [1,006 B]
    Fetched 5,641 B in 2s (2,019 B/s)
    Reading package lists... Done
    
    ## Run `apt-get install nodejs` (as root) to install Node.js v6.x and npm
    
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
      nodejs
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 8,790 kB of archives.
    After this operation, 41.1 MB of additional disk space will be used.
    Get:1 https://deb.nodesource.com/node_6.x stretch/main armhf nodejs armhf 6.12.3-1nodesource1 [8,790 kB]
    Fetched 8,790 kB in 11s (771 kB/s)
    Selecting previously unselected package nodejs.
    (Reading database ... 63014 files and directories currently installed.)
    Preparing to unpack .../nodejs_6.12.3-1nodesource1_armhf.deb ...
    Unpacking nodejs (6.12.3-1nodesource1) ...
    Setting up nodejs (6.12.3-1nodesource1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Node.js installation Done!
    Cloning MagicMirror ...
    Cloning into 'MagicMirror'...
    remote: Counting objects: 8976, done.
    remote: Compressing objects: 100% (8/8), done.
    remote: Total 8976 (delta 3), reused 3 (delta 1), pack-reused 8967
    Receiving objects: 100% (8976/8976), 11.48 MiB | 1.09 MiB/s, done.
    Resolving deltas: 100% (5077/5077), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    npm WARN deprecated coffee-script@1.10.0: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
    npm WARN prefer global coffee-script@1.10.0 should be installed with -g
    npm WARN prefer global jsonlint@1.6.2 should be installed with -g
    
    > uws@0.14.5 install /root/MagicMirror/node_modules/uws
    > node-gyp rebuild > build_log.txt 2>&1 || exit 0
    
    


  • No you are stuck ^^
    It is done. You can safely ignore warnings 😉
    Just copy and rename the sample config.js and start the mirror in the MagicMirror folder with using „npm Start“
    Or better use pm2
    Take a look at the great tutorials in the Forum.