MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Problem updating to v2.3.1



  • @Kristianson
    move or remove the files below

    dangerfile.js
    fonts/yarn.lock
    module-types.ts
    tests/configs/data/StripComments.json
    tests/configs/data/TranslationTest.json
    tests/configs/data/en.json
    tests/e2e/translations_spec.js
    tests/unit/classes/class_spec.js
    tests/unit/classes/deprecated_spec.js
    tests/unit/classes/translator_spec.js
    tests/unit/classes/utils_spec.js
    vendor/yarn.lock
    yarn.lock
    

    and then run

    git pull && npm install
    


  • removed those and now:

    pi@raspberrypi_7:~/MagicMirror $ sudo git pull && npm install
    Removing tests/unit/translations/same_keys.js
    Removing tests/unit/functions/class_spec.js
    Auto-merging modules/default/currentweather/README.md
    CONFLICT (content): Merge conflict in modules/default/currentweather/README.md
    Automatic merge failed; fix conflicts and then commit the result.

    Perhaps I should just re-install it? I even removed the currentweather default module (directory and the files)…


  • Module Developer

    With any of the default modules… If you made any changes to the .js files or the README.md files, AND, you would like to keep those changes… TRY THIS:

    cut and paste any of the default modules from the MagicMirror directory to any other directory.
    You also need to do the same for the package.json, package-lock.json, and your config.js file if there are any additional modules that have been added.

    then do the ‘git pull $$ npm install’

    when it is done, replace those files in the new MagicMirror that just got installed with the ones you saved from your old MagicMirror.

    then do ‘npm rebuild’

    It took a couple of times starting the MagicMirror to get all the changes to take…

    this also fixes the currentweather module problem…

    and the blank screen problem…



  • Thank your for the reply. I will give that a try… failing that I am going to re-install it…



  • Well, I couldn’t get it to work, so I just did a rebuild of the 2 mirrors. I keep a base build of the MM image anyway, so it only took an hour to recreate them both from scratch.



  • So I reinstalled it, however now when the MagicMirror starts the screen is just black…



  • @Bob said in Problem updating to v2.3.1:

    Not sure what I’ve done but when I run a git pull I now have a message that says I need to run “git commit -a” to fix the issues.

    What would happen if I did that ? Would it overwrite the main branch, or just create my own version of that branch ? I don’t have a git account, so would that cause issues as well ?

    I ran the “git commit -a”, exited that screen, then ran sudo git pull & npm install and it worked for me then…Had the same issues above before that


Log in to reply