MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Problems with installing the Mirror new



  • Hi there,
    because I was not able to move to a sd card with bigger size, I tried a new Installation. This also did not worked.
    I took the actually raspian full streich, just like recommended. This works perfect. Then I used ssh and installed MM automatic with Code from michmich. Everything fine.Question about using pm2 I answered with y. I saw no errors. After starting with the command on the last line I got these errors After sockets connected & modules startet.

    Whoops! There was an uncaught exception…

    { Error: listen EADDRINUSE 127.0.0.1:8080

    at Object._errnoException (util.js:1024:11)

    at _exceptionWithHostPort (util.js:1046:20)

    at Server.setupListenHandle [as _listen2] (net.js:1351:14)

    at listenInCluster (net.js:1392:12)

    at GetAddrInfoReqWrap.doListen [as callback] (net.js:1501:7)

    at GetAddrInfoReqQrap.onlookup [as oncomplete] (dns.js:97:10)

    code: ´EADDRINUSE´,

    errno: ´EADDRINUSE´,

    syscall: ´listen´,

    address: ´127.0.0.1´,

    port: 8080 }

    MagicMirror will not quit, but it might be a good Idea to check why this happend. Maybe not internet connection?

    If you think this really is an issue, please open an issue on …

    Launching application.

    After that there was no way for ssh. System hangs on. Mirror doesnt start. There was allready the raspian Desktop also after power off.
    Please help. Dont know what I made wrong.


  • Module Developer

    @hakupapa said in Problems with installing the Mirror new:

    Error: listen EADDRINUSE 127.0.0.1:8080

    It would appear that something else is using port 8080 which MM needs



  • Thx for the answer. I attempted a little bit and I found the problems.
    The biggest problem was the new but cheap 128 GB card. I had also problems while starting. That seems to be also the problem for other Installations.
    The error in my first thread is not important. I used another smaller sd card and I got the error too but the mm works allright. So the problem seems to be solved.
    Greetings from Hakupapa



  • I got the same problem.

    Before the update i had a MM with three extra modules, namely:
    MMM-AssistantMk2
    MMM-NotificationTrigger
    MMM-Hotword

    I also had teamviewer installed.
    Everything worked fine.
    I had the update message an i did the git pull && npm install

    Didn’t had any updates during the update.
    After the update i tried to start the mirror the normal way and i got the error like it’s mentiont at the beginning of this topic.

    What’s causing this and how to correct it?


  • Module Developer

    Usually that case is caused by multiple execution of MM.
    “pm2 stop mm” then “pm2 start mm” Or just reboot.



  • @sean
    thanks for the reply.
    I don’t use pm2, i’m starting the mirror with “DISPLAY=:0 npm start”

    To be sure i tryed the “pm2 stop mm” but like suspected i’m getting the “bash: pm2: opdracht niet gevonden” message.



  • @sean
    Your comment about multiple executions of mm got me thinking.
    before the update i started the mirror. “pm2” didn’t worked and the mirror was shutdown, through ctrl+c.

    So i did a restart of the pi and… now it works 😃

    So the sollution (for me in this case) was restarting the pi, so it forgets the instance of mm 😃