MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Calendar Module +1 day Error



  • Hi! My Magic Mirror is showing that Halloween is in a month and then lists Nov 01 next to it (this is from the US Holidays calendar). Also other dates are offset by +1 day. Also, when I added an additional calendar, it’s showing incorrect dates for events… Is this a known ongoing bug? Any alternative calendar modules I should consider?



  • Please see an example of what I am seeing. Columbus day is on the 8th (not 9th), Haloween is on October 31 (not November 01) and the rest of the listed dates are wrong too… When I added a calendar with birthdays, I also was seeing a similar error so I removed it to see if this was the cause. My Pi’s clock is set to the correct timezone. Any advice around this would be greatly appreciated. It wasn’t doing this until recently and the only thing I had done was to add the birthday calendar (which I removed).

    I have tried reloading the modules, quitting and restarting magic mirror and rebooting the Pi. All to no avail.

    0_1538595890922_Screen Shot 2018-10-03 at 3.44.04 PM.png



  • What is the system time one set to?

    Where are u located?



  • @sdetweil said in Calendar Module +1 day Error:

    What is the system time one set to?

    Where are u located?

    I am in New York / Eastern time zone. System time is set to Eastern / New York.

    I installed the MMM-MyCalendar module and it’s working with correct dates etc. I’d prefer to use the default one though.

    Current default time zone: 'America/New_York’
    Local time is now: Wed Oct 3 16:09:57 EDT 2018.
    Universal Time is now: Wed Oct 3 20:09:57 UTC 2018.



  • Hi! If you put showEnd: false, in your config for calendar solves the problem.
    Oct 9th is and nov 1st when it ends.



  • @nilnik said in Calendar Module +1 day Error:

    Hi! If you put showEnd: false, in your config for calendar solves the problem.
    Oct 9th is and nov 1st when it ends.

    Hi! I did try this and restarted. The problem persists. I placed that value in two locations… The config for the module and the config for the calendar. Neither has any impact. I also did not see this option mentioned in the GitHub documentation. Perhaps it’s an old value which was retired? Your observation does seem valid. I just wonder why it’s stuck in this mode for me.

    {
                            "module": "calendar",
                            "header": "Calendar",
                            "position": "top_left",
                            "showEnd": "false",
                            "config": {
                                    "calendars": [
                                            {
                                                    "symbol": "calendar-check-o ",
                                                    "url": "webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics",
                                                    showend: "false",
                                                    "color": "#FFFFFF"
                                            },
    


  • Hello again!
    I Think that you shouldn’t put quotes rond false
    Here is my config:

    module: ‘calendar’,
    header: ‘Kalender, Helg-och födelsedagar’,
    position: ‘top_left’,
    config: {
    colored: true,
    timeFormat: ‘absolute’,
    maximumEntries: 12,
    urgency: 2,
    dateFormat: ‘Do MMM’,
    fullDayEventDateFormat:‘Do MMM’,
    showEnd: false,
    getRelative: 48,



  • @nilnik said in Calendar Module +1 day Error:

    Hello again!
    I Think that you shouldn’t put quotes rond false
    Here is my config:

    module: ‘calendar’,
    header: ‘Kalender, Helg-och födelsedagar’,
    position: ‘top_left’,
    config: {
    colored: true,
    timeFormat: ‘absolute’,
    maximumEntries: 12,
    urgency: 2,
    dateFormat: ‘Do MMM’,
    fullDayEventDateFormat:‘Do MMM’,
    showEnd: false,
    getRelative: 48,

    Hi! That did it! Thank you for your patience and help! I greatly appreciate the help and will certainly help others whenever I can.

    To get this issue resolved, I had to include the showEnd value AND set the timeFormat to absolute as you have. Now my calendar displays the date correctly…

    0_1538659054639_Screen Shot 2018-10-04 at 9.17.02 AM.png



  • Glad to help. Have a nice weekend



  • Edit: I thought I had this problem but I put

    			timeFormat: 'absolute',
    			showEnd: false,
    

    in the wrong section. Once I put it in the config it worked.

    Thanks