MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Troubleshooting MagicMirror



  • Hi guys,
    First of all, i'm new in this forum and having a beginning level on this project that I would customize it on my own.
    - First, the installation step doesn't finish correctly using the version 
    Debian Stretch with Raspberry Pi Desktop (Kernel version 4.9), i got the error unable to install dependencies :
    Check current Node installation ...
    Node currently installed. Checking version number.
    Minimum Node version: v5.1.0
    Installed Node version: v8.11.1
    No Node.js upgrade necessary.
    Cloning MagicMirror ...
    Cloning into 'MagicMirror'...
    remote: Enumerating objects: 282, done.
    remote: Counting objects: 100% (282/282), done.
    remote: Compressing objects: 100% (251/251), done.
    remote: Total 282 (delta 34), reused 127 (delta 21), pack-reused 0
    Receiving objects: 100% (282/282), 385.56 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (34/34), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    bash: line 112: npm: command not found
    Unable to install dependencies!
    Can I get some help from u guys?
    Thank you all
    


  • @oththegentel delete the Magic Mirror Folder and download it again I had similar on my pi and it installed the dependence’s after that



  • @dazza120 thank you for your response.
    I renamed the folder and tried to install it again same error.
    Actually, i just downloaded the latest version of node and trying to install it but it takes a lot of time (waiting for headers (connection failed IP 173.209.xx.xx:80))
    Did you had the same thing? Can i just stop interrupt and go with the manual install instead of automatic??



  • @oththegentel delete the folder and do the manual method I’m not sure if pm2 start mm work doing it that method, ie when you reboot it I did put the pm2 script in a thread on the site that worked for me, so use the manual method then reboot and see if the mirror comes back online if not look for pm2 restart
    If PM2 gives you trouble use https://forum.magicmirror.builders/topic/8987/pm2-error/13



  • @oththegentel your pi up to date? Get all updates for the pi and try again


  • Project Sponsor

    @oththegentel - You can install over top of a busted installation. Any attempts to install dependencies that you already have in place will automatically be intercepted and you’ll see a message saying that there’s nothing to install.

    It sure sounds like Node didn’t install correctly. The connection issue is probably on their end (I’m assuming your local network isn’t in the 173.209.xxx.xxx range). This is most likely temporary and once someone notices, they’ll get it back up & running. Keep trying!



  • @dazza120 Perfect thanks a lot man it’s working now.
    So the next step, i copied the file /home/pi/MagicMirror/config/config.js.sample to /home/pi/MagicMirror/config/config.js
    Do I have to modify the script in config.js or go to inside each folder in modules and customize them?



  • @bhepler Thanks for your help, it’s working now. I deleted the folder and installed it with the manual method 👍



  • Do I have to modify the script in config.js or go inside each folder in modules and customize them?


  • Project Sponsor Module Developer

    @oththegentel said in Troubleshooting MagicMirror:

    Do I have to modify the script in config.js or go inside each folder in modules and customize them?

    You should only make changes to your config.js when adding or removing the modules you want to display. It is not recommended that you modify the module files.


Log in to reply