MagicMirror² v2.6.0 is available! For more information about this release, check out this topic.

ipwhitelist - a lot of issues... can't connect remotely ..



  • Some days now, i try to get my MM running on a Raspberry (Zero, B3A+) but without Access

    two main issues occurs…

    i can’t access remotly …

    whatever i tried in “config.js”

    this is what i tried

    var config = {
    address: “localhost”, // Address to listen on, can be:
    // - “localhost”, “127.0.0.1”, “::1” to listen on loopback interface
    // - another specific IPv4/6 to listen on a specific interface
    // - “”, “0.0.0.0”, “::” to listen on any interface
    // Default, when address config is left out, is “localhost"
    port: 8080,
    ipwhitelist: [],
    //ipWhitelist: [”::fff:0.0.0.0/1", “::fff:0.8.0.0/1”, “::fff:128.0.0.0/2”, “::fff:192.0.0.0/3”, “::fff:224.0.0.0/4”, “127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “192.168.2.54”],
    //ipWhitelist: ["::ffff:192.168.2.1/120", “127.0.0.1”, “::ffff:127.0.0.1”, “::1”], // Set [] to allow all IP addresses
    // or add a specific IPv4 of 192.168.1.5 :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.1.5”],
    // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.3.0/28”],

    for Explanation my Home LAN is addressed with 192.168.2.x…

    i have installed it with PM2

    if i start it locally with

    startx (cause “chromium-browser -Kiosk http://localhost:8080” gives an GTK-Error) and after that
    DISPLAY=:0 chromium-browser -Kiosk http://localhost:8080" it starts but give me an Warn Message that Address “localhost” is already in use …

    any Ideas…

    The last entrys for “ipwhitelist” i found were form one year ago…

    basicliy i want to start it jast locally on my Pi …



  • @big11 said in ipwhitelist - a lot of issues... can’t connect remotely ..:

    address: “localhost”,

    Try change address: “localhost” to “0.0.0.0”



  • And please use the Markdown features of the board when pasting code or logs.



  • @plati

    got it … thank you…

    but the ipwhitelist Parameter are not very handsome

    so i did a

    ipwhitelist: [],
    

    and that works…

    further i will look for the correct Syntax to grant Access for Special addresses outside my LAN…