Looking for beta testers for MMM-Remote-Control


  • Moderator

    I developed the Remote Control Module (Link to Showcase Thread), and am currently making some major changes, to allow editing the config.js in a UI.
    Judging from the traffic of the repository, this module is now being used by more people than just me, so I would like to make sure to gather feedback and fix possible bugs before releasing changes to everyone.

    If you are using my module and are interested in helping me by testing the version on my develop branch, I would greatly appreciate it. Note that this version also might not work as intended all the time and can contain bugs. If you are afraid of messing up your config.js you should probably stay on the master branch. Even though backups should be created, these currently need to be restored manually.

    If you want to help, please change to the develop branch (I assume you already installed it):

    cd ~/MagicMirror/modules/MMM-Remote-Control
    git fetch origin
    git checkout develop
    npm install # install new dependencies
    

    I will post here when new changes are ready for testing, if you want to be updated about new changes, you can watch this thread.
    Also I will try to keep my trello board up to date.

    Please post ideas, feedback and bugs concerning the develop branch in this thread (or make comments on the trello board).


  • Moderator

    Currently the biggest changes to test are:

    • the new UI for editing the config.js
    • adding/installing/configuring/removing modules

    I am looking for feedback on these steps, as well as:

    • where confirmation messages should and should not appear
    • the menu structure updates
    • ideas on how to assemble a list of all available modules (currently being pulled from the wiki)


  • @Jopyth
    Ok, nice one!
    Even I’m missing the “switch on for xy minutes” feature ;)

    Anyway, what I realized is:

    • saving the configuration of shown modules causes the mirror to restart. Maybe there should be a confirmation message.
    • if you press “save” without a change, there could be a message telling you that there is no change and thus restart is not necessary.
    • on the smartphone landscape doesn’t show the installed mod list, on the tablet it does.
    • do you need two different switches/lines to show/hide all? Technical reason? Otherwise it could earn you some space.
    • Netatmo is shown twice in the “New module” list -> probably because it is twice in the wiki as well :)

    Installation of new module - I tried the “Callmonitor-Current-Call” - worked smoothly. Even editing the position and header was easy! Sweet!

    2nd installation - this time “Motiondetecter” - ended in an error. The mirror crashes in the moment I push the Download button.
    Retried to download but it seems like it the pi freezes. Tried to restart but i hang up. Had to disconnect it from the power supply.
    Tried again. Same thing. Error while downloading. This time I went back in the menu to restart the mirror. Couldn’t download but the mirror didn’t die. Maybe it’s the motion detector and the neccessary steps to activate the cam module?
    The folder “motiondetector” was created but it is empty.

    3rd installation - Local Transport - Error after starting to download. The mirror restarted.

    Hmm, any module I try causes a crash and restart of the mirror in the moment I press the DL button.

    Any information you need?

    Nevertheless this is a great configuration tool!


  • Moderator

    @done Thank you very much!

    I am still on the hunt of the restart thing. This is actually a bug, but I am not sure what causes it (if any file in the MagicMirror directory changes, the process restarts). Only happens on the raspberry pi though, and thus harder to debug. If anyone has an idea…

    I will see if I can find out what causes the errors on download, since that is the part that actually should work.

    It does not show the installed modules list on smartphone in landscape?


  • Module Developer

    I’ll join ;-)



  • I’ve joined…
    Tried some and ran into some trouble…
    Will give you a more detailed report when I have the time…

    I noticed all parameters and values in config.js are wrapped in quotes…
    Maybe that’s why I’m seeing

    0|mm       | ** Message: console message: http://localhost:8080/js/main.js @38: TypeError: undefined is not an object (evaluating 'wrapper.appendChild')
    0|mm       | ** Message: console message: http://localhost:8080/js/main.js @130: TypeError: null is not an object (evaluating 'moduleWrapper.getElementsByClassName')
    

    The second line is repeated a couple of time (for each module?)…

    And when I tried to save eanbled/disabled modules from the remote, the pm2 logs showed an error about insufficient rights…
    Sorry for not having the error log…

    The config.js now looks like (just a small part):

    var config =
    {
        "port": 8080,
        "kioskmode": false,
        "language": "nl",
        "timeFormat": 24,
        "units": "metric",
        "modules": [
            {
                "module": "MMM-Remote-Control",
                "config": {}
            },
            {
                "module": "clock",
                "position": "top_left",
                "header": "",
                "config": {
                    "displayType": "digital",
                    "timeFormat": 24,
                    "displaySeconds": false,
                    "showPeriod": false,
                    "showPeriodUpper": false,
                    "clockBold": false,
                    "showDate": false,
                    "analogSize": "100px",
                    "analogFace": "simple",
                    "analogPlacement": "bottom",
                    "analogShowDate": "top",
                    "secondsColor": "#888888"
                }
            },
    '''
    etcetera...


  • @Jopyth said in Looking for beta testers for MMM-Remote-Control:

    It does not show the installed modules list on smartphone in landscape?

    Exactly. I just checked again.
    I use a Galaxy S6 (just for the dimensions) and I experience that on chrome and the default browser.
    I have an idea for the reason.
    You work with something like frames.
    You have the fix navigation area with “Back”, “Brightness” etc. on top and you have a scrollable list with the installed mods below.
    When I go for landscape, there is no chance to get to the scrollable area since the fix area takes already whole of the screen.
    The solution could be to make the whole screen scrollable.
    At least for small mobile devices.
    Or you prevent the browser from going into landscape :D

    I guess this is an easy one.

    I tried to install modules. MMM-hue and FUEL worked but I had no time to configure them. But they showed on the mirror.

    Let me know if I should retry.


  • Moderator

    @done Yes the fixed area there takes up way to much space.

    Does it still do the restart thing? If yes, can you check the output of pm2 show mm and see if Watch & Reload is enabled? I am currently trying to figure out a way to stop pm2 from restarting on changes of files.


  • Moderator

    @rvdgeer The quotes wrapping should be ok, since whether the key of an object is wrapped in quotes or not, does not make a difference as far as I know. However something is still wrong. Are these console messages coming from your browser?

    And did the saving of hidden/shown modules work before you changed to the development branch? Did you change permissions on any folder, and do you have a dedicated user which runs you MagicMirror?



  • @Jopyth said in Looking for beta testers for MMM-Remote-Control:

    Does it still do the restart thing?

    I installed the new dependencies and now it seems to work. :)



Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.