MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Setting Up Magic Mirror on Ubuntu issue



  • I’ve tried the manual install. After going through several audit installs, this is the final one that I could not get through. Anyone have any experience in resolving this issue?

    Note: I’m using ubuntu mate on my pi 3 instead of Raspbian

    Thanks

    0_1547881335146_File_000.jpeg


  • Module Developer

    @duhcompuder

    npm i lodash@4.17.5

    this fixed mine



  • Thank you, I was able to fix the lodash issue only through a root terminal.

    But a warning pops up saying:

    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed.
    You must install peer dependencies yourself.


    I read somewhere that this could be an npm issue or a bug. Still trying to figure it out. The issue now is to find acorn@^6.0.0 and the location to install it to. Hopefully that should fix the issue, any ideas?


  • Module Developer

    @duhcompuder

    Install the same way: npm i acorn@latest

    with any of those kind of warnings do the same.

    I’m having issues right now getting MM to run on a new install of Ubuntu.
    Keep getting errors that the sh start.sh or something like that isn’t valid.
    Can’t figure it out, had this issue once before a long time ago and not sure how I fixed it.



  • I don’t even know how to describe this… So after fixing the acorn issue, the lodash issue reappeared. For some reason, I can no longer fix the lodash issue (even with sudo and root terminal). It just would not let me install lodash 4.17.5 or even the newest version because of the vulnerability.

    I’m hypothesizing that MM might be using something that is dependent on a previous version of lodash that conflicts with Ubuntu’s security vulnerability


    Here is an article referring the lodash vulnerabilities existing in versions prior to 4.17.11:

    https://resources.whitesourcesoftware.com/blog-whitesource/top-5-open-source-security-vulnerabilities-november-2018


    Conclusion.

    After updating my system’s lodash file to 4.17.12 through a root terminal, I was able to resolve updating issues related to lodash within the MM directory. The only issue is the message about the vulnerability that is not resolvable with npm audit fix

    Starting the program displays the message that MagicMirror is online yet the UI does not change.

    I’m going to stick with Raspbian for now


  • Project Sponsor Module Developer

    @duhcompuder said in Setting Up Magic Mirror on Ubuntu issue:

    I’m going to stick with Raspbian for now

    I don’t know if this matters but I use ubuntu 16.04 LTS exclusively on several machines, including my dev machine. The one time I tried to install MM on ubuntu 18.xx I encountered all the vulnerabilities that you are talking about. I immediately wiped the machine and installed ubuntu 16.04 LTS. Then I installed MM without a single problem. That includes the most current MM, v2.6.0



  • @mykle1 said in Setting Up Magic Mirror on Ubuntu issue:

    @duhcompuder said in Setting Up Magic Mirror on Ubuntu issue:

    I’m going to stick with Raspbian for now

    I don’t know if this matters but I use ubuntu 16.04 LTS exclusively on several machines, including my dev machine. The one time I tried to install MM on ubuntu 18.xx I encountered all the vulnerabilities that you are talking about. I immediately wiped the machine and installed ubuntu 16.04 LTS. Then I installed MM without a single problem. That includes the most current MM, v2.6.0

    @Mykle1

    I’ve just installed Ubuntu 14.04 on my laptop (to get full support for Snowboy), but when I run ‘npm start’, it starts the application but dont “open the magicmirror”. I can use my browser to dial into it.

    Do you know if I need to add something extra to make it show upon running the application?

    I run GNOME as desktop.



  • @thestigh i just upgraded to 2.6.0

    this is what I see in the console window when I do npm start, obviously some of these modules are specific for my system

    Starting MagicMirror: v2.6.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    handler helper in init
    Module helper loaded: MMM-SleepWake
    Initializing new module helper ...
    Module helper loaded: MMM-ImagesPhotos
    Initializing new module helper ...
    Module helper loaded: MMM-voice
    Initializing new module helper ...
    Module helper loaded: WaterLevels
    All module helpers loaded.
    Starting server on port 8086 ...
    Server started ...
    Connecting socket for: MMM-SleepWake
    handler helper in start
    Connecting socket for: MMM-ImagesPhotos
    Starting node helper for: MMM-ImagesPhotos
    Connecting socket for: MMM-voice
    Starting module helper: MMM-voice
    Connecting socket for: WaterLevels
    Starting module: WaterLevels
    Sockets connected & modules started ...
    Launching application.
    

    do you see anything different?

    npm start  dev
    

    would open the developers console, and then change to the console tab to check for any errors (red text)


  • Project Sponsor Module Developer

    @thestigh said in Setting Up Magic Mirror on Ubuntu issue:

    Do you know if I need to add something extra to make it show upon running the application?

    No, you shouldn’t need anything “extra” although I only use ubutnu 16.04 LTS. I’m reading through some posts that mention the same exact problem that you’re experiencing, where MM is running but can only be seen remotely.

    As suggested by @sdetweil, run npm start dev in your MagicMirror directory and choose the Console tab in the resulting window. Then copy/paste/report any errors there and/or in your terminal.

    You might also want to make sure that all updates have been performed on your current ubuntu installation as well as ensuring that you have current stable versions of node and npm.



  • also check the node and npm versions,

    node -v
    

    and

    npm -v
    

Log in to reply