MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MMM-PIR-Sensor with Radar sensor( RCWL-0516)


  • Project Sponsor

    Hi all,
    I think I’ve read somewhere that MMM-PIR-Sensor works as well with a radar seonsor (RCWL-0516) behind glass.
    Now for me it currently gives very odd behaviour.
    I get a USER_PRESENCE notification and a “refresh” of the monitor (turn off shortly and turn it on again) every few seconds even if noone is in front of the mirror.
    No other messages, no errors.

    I have the radar sensor installed without any resistor in between.
    Nothing special in the config.

            //disabled: true,
            module: 'MMM-PIR-Sensor',
            config: {
                sensorPin: 17,
                powerSavingDelay: 20,
            }
    

    Can anyone confirm that this module works with a radar sensor and possibly help me out?

    Thanks!


  • Project Sponsor

    I tweaked the module logging a bit to include the time and there’s obviously something systematic happening. This is what I get after some time (as said, messages included with console.log.:

    0_1563220295659_bc9c404c-3600-4d22-998b-de4c3602babc-image.png

    It’s always turning on after 1-2 minutes and turning off after 3 seconds immediately.

    After some googling I’m getting the feeling that the radar sensor is not the best way to go…



  • I am using the same sensor even on the same GPIO pin with the module. First it didn’t worked, but after doing an update of the module everything is running like expected.
    Did you connected the sensor correct?


  • Project Sponsor

    @MacMirror

    Checked the pins several times.
    Are you using a resistor or anything in between? Or is it wired directly?



  • The sensor is connected directly.

    Did you wired the Vin to 5V on the Raspi? Don’t use the 3v3-Pin!