MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

mail module problem



  • Hello
    I just installed MagicMirror and all the native modules works fine, I have to change the language,
    I adapted weatherforecast, currentweather, newsfeed, for calendar I stopped it because it’s american, I put pictures that turn in loop,
    but when I want to install my mailbox with a terminal I have a problem!
    I open a terminal I start with
    cd ~ / MagicMirror / modules
    then
    git clone https://github.com/ronny3050/email-mirror.git
    then
    cd email
    npm install
    i will then go to config.js where i install
    {
    module: ‘email’,
    position: ‘top_left’,
    config: {
    user: "xxxxx@gmail.com",
    password: “xxxxx”,
      host: “imap.gmail.com”,
    port: 993,
    tls: true,
    authTimeout: 10000,
      numberOfEmails: 5,
      fade: true
         }
    }
    of course I put my personal details
    and when I restart MagicMirror
    with the command … pm2 start mm … in a terminal I returned a black page with an error message
    here you can help me
    Thank you papinel


  • Project Sponsor

    @papinel Hi. Your config looks wrong. Can you try changing it to match the below?

    {
    module: 'email',
    position: 'top_left',
    header: 'Email'
    config: {
    	accounts: [
    	user: 'xxxxx@gmail.com',
    	password: 'xxxxx',
      host: 'imap.gmail.com',
      port: 993,
      tls: true,
      authTimeout: 10000,
      numberOfEmails: 5,
    	],
      fade: true
         }
    }
    


  • Hello sir
    could you tell me if I use the right orders? with the terminal
    cd ~ / MagicMirror / modules
    git clone https://github.com/ronny3050/email-mirror.git
    cd email
    npm install
    because when i install your answer in my config.js
    I have my black page with the error message
    please create config file
    if you this message is ready for your config file probaly contains an error
    this message only happens when I install
    in the config.js
    Thank you very much for your help
    papinel


  • Project Sponsor Module Developer

    @papinel you didnt install it properly, the instructions say git clone https://github.com/ronny3050/email-mirror.git email, either start from scratch or rename the directory email-mirror to email and install the dependencies again.


  • Project Sponsor

    @papinel I just installed the module and set it up and it works perfect with the setings that I gave you above. As @strawberry-3-141 mentioned, you may want to start from scratch with the module installation.

    • git clone https://github.com/ronny3050/email-mirror.git email

    • cd email

    • npm install



  • Hello,
    I’m sorry, but really sorry I still did not pay the email module for my magicmirror I did everything you told me
    first the 3 orders by the terminal

    git clone https://github.com/ronny3050/email-mirror.git email
    cd email
    npm install

    return by image

    pi @ raspberrypi: ~ $ git clone https://github.com/ronny3050/email-mirror.git emailCloning in ‘email’ …
    remote: Enumerating objects: 3, done.
    remote: Counting objects: 100% (3/3), done.
    remote: Compressing objects: 100% (3/3), done.
    remote: Total 63 (delta 0), reused 0 (delta 0), pack-reused 60
    Unpacking objects: 100% (63/63), done.
    pi @ raspberrypi: ~ $ cd email
    pi @ raspberrypi: ~ / email $ npm install
    (node: 2831) [DEP0022] DeprecationWarning: os.tmpDir () is deprecated. Use os.tmpdir () instead.
    npm WARN package.json email@0.0.1 No repository field.
    npm WARN package.json email@0.0.1 No license field.
    npm WARN deprecated mailparser@0.6.2: Mailparser versions older than v2.3.0 are deprecated
    npm WARN deprecated mimelib@0.3.1: This project is unmaintained
    underscore@1.9.1 node_modules / underscore

    debug@2.6.9 node_modules / debug
    └── ms@2.0.0

    imap@0.8.19 node_modules / imap
    ├── utf7@1.0.2 (semver@5.3.0)
    └── readable-stream@1.1.14 (string_decoder@0.10.31, isarray@0.0.1, inherits@2.0.4, core-util-is@1.0.2)

    mailparser@0.6.2 node_modules / mailparser
    ├── mime@1.6.0
    ├── mimelib@0.3.1 (addressparser@1.0.1)
    ├── uue@3.1.2 (escape-string-regexp@1.0.5, extend@3.0.2)
    └── encoding@0.1.12 (iconv-lite@0.4.24)
    pi @ raspberrypi: ~ / email $

    as indicate by
     mumblebaj

    then I copy in config.js

    {
    module: ‘email’,
    position: ‘top_left’,
    header: ‘Email’
    config: {
    accounts: [
    user: ‘xxxxx@gmail.com’,
    password: ‘xxxxx’,
      host: ‘imap.gmail.com’,
      port: 993,
      tls: true,
      authTimeout: 10000,
      numberOfEmails: 5,
    ]
      fade: true
         }
    }

    as indicated by
    mumblebaj

    in my home / pi I have an email folder, but when I run pm2 start mm, I find my page that marks me errors, I really do not know or I make a mistake I am to the letter your advice

    I really do not know where I am making a mistake I am on the letter your advice
    I will stop bothering you with my problem, I will not use the clone mail
    I pass you all this through a .odt file
    thank you so much
    papinel



  • @papinel ALWAYS git clone ONLY with the MagicMirror/modules folder as the current folder, u have them all over the place…



  • Hello
    thank you for your answer, but could develop a little more because I have trouble understanding to execute this module
    thank you so much
    papinel



  • @papinel when someone tells u to install a module on MagicMirror
    you do

    cd ~/MagicMirror
    cd modules
    git clone .....
    cd ../config
    nano config.js
    ... add the config info for this module
    ... save the updated config (ctrl-o to write, ctrl-x to exit nano)
    cd ..
    
    either use pm2 to  start MagicMirror again or the installers/mm.sh
    

    in general, you should not need to change anything IN the module folder itself