MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

3rd Party Modules with APIs not loading.

  • I’m brand new to MagicMirror (as of a few days ago) and moderately new to Raspberry Pis and was able to successfully configure my Google Calendar with local Weather and local Forecasts.

    However, I’ve installed a number of third party modules that do not move past “Loading.”

    I’ve downloaded a handful of third party modules and the only ones that have issues are ones that are connecting to an API or an external source.

    I’m suspicious that this might be a general Raspberry Pi configuration causing issues, but that doesn’t explain why the Calendar and Weather work. In a browser, I can connect to the internet.

    I’m not necessarily looking for an absolute answer (that would be nice…), but I’m also interested in knowing how I can further troubleshoot this and narrow down the issue.


  • ‘loading’ is a hard coded message, put out until the module gets data. then the data replaces the ‘loading’ text…

    so, no data has come in…

    open the developers window, ctrl-shift-i, and select the tab labeled ‘console’ and scroll up to see any errors (usually red text)

  • Excellent suggestion!

    Interestingly enough, the only error logged in the console was for the openweathermap.

    There doesn’t appear to be any errors related to any other modules.


  • @bflbarlow what did you configure for the info you wanted to display?

    i tested for baseball, and got a block of data back

  • Here’s what I have for my config for those four 3rd Party Modules.

    The MMM-Launch config is directly copy/pasted from the module’s README, minus the location to “bottom_right”.

    				module: "MMM-MyStandings",
    				position: "top_left",
    				config: {
    				updateInterval: 60 * 60 * 1000, // every 60 minutes
    				rotateInterval: 1 * 60 * 1000, // every 1 minute
    				sports: [
    				{ league: "NBA", groups: ["Atlantic", "Central", "Southeast", "Northwest", "Pacific", "Southwest"] },
    				module: "MMM-NFL",
    				position: "top_left",
    				config: {
    				focus_on: "GB"
    			module: "MMM-CollegeFootballTop25",
    			position: "top_left",
    			config: {
    				headerText: "AP Top 25",
    				teamsToShowAtATime: 2,
    				showColumnHeaders: false,
    				showPollWeekAndDate: false,
    				textClass: "small",
    				highlightTeams: ["Wisconsin::#6a2c3e"],
    				colorRankChange: false,
    				onScreenRefreshRate: 6000,
    				animationSpeed: 3000,
        		module: 'MMM-Launch',
        		position: 'bottom_right',               // Best in left or right region
        		config: {
    				showPix: "Yes",                 // No = No picture
    				showAgency: "Yes",              // No = Launch Agency not shown
    				showDescription: "No",          // Yes = full description of mission under picture
    				useHeader: false,               // false if you don't want a header
    				header: "We have liftoff!",     // Any text you want. useHeader must be true
    				maxWidth: "300px",

  • Project Sponsor Module Developer

    @bflbarlow said in 3rd Party Modules with APIs not loading.:

    The MMM-Launch config is directly copy/pasted from the module’s README, minus the location to “bottom_right”.

    I just ran this module. There is a delay in loading (< 30 seconds). I believe it to be an api delay issue because the module will run in less than 30 seconds.

    I just took this screenshot.

    0_1571354538989_Screenshot from 2019-10-17 19-15-12.png

  • Project Sponsor Module Developer

    And another as it goes through the rotation.

    0_1571354630587_Screenshot from 2019-10-17 19-23-23.png

  • I’m glad yours works.

    Mine still doesn’t.

    If 30 seconds is what I have to wait, then I’m already 120+ times past that (over an hour) with no rotation.

    I’m curious if you have any suggestions on things to try to help narrow this issue down.

  • Project Sponsor Module Developer


    Try disabling the other modules to see if it loads. If not, I would delete the MMM- Launch module folder and clone it again, trying it alone again. If that does not work then something else is amiss. I assure you, the module does work and it should work for you.

  • I’ll give that a try.

    I’m not concerned with that specific module not working. 3rd Party Modules I’ve installed that do not utilize APIs work perfectly well and the default modules work perfectly well as well.

    It is a trend however, that of the six total 3rd Party Modules that I have tried and tested that do connect to APIs, none of them appear to be receiving data, which is why I am still slightly suspicious about something being wrong in the general Raspberry Pi configuration. But that wouldn’t explain why the default modules work perfectly well despite pulling from the openweathermap API.

Log in to reply