MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Background Image question ~ EasyBack



  • Hi there,
    Thought the idea of adding my own desktop background image to my Pi would be awesome… Came across a module and thought I would give it a go…

    So this is what I have done so far…>>

    Got to modules and ran gitclone
    Dropped my own image into the EasyBack module folder as instructed
    Copied the config.js options however now get config error
    I am only interested (at this time) for a desktop image to appear rather than the use of the video part so when I used the entry I did leave the video part and YouTube part as “” - hope that is correct? Or am I to remove the videoName & youTubeID parts completely?

    {		
    			module: "MMM-EasyBack",
    			position: "fullscreen_below",
    			config: {
    			    bgName: "NHS.jpg",
    			    videoName: "",
    			    youTubeID: "",
    			    height: "1080px",
    			    width" "1920px",	
    		}
    
    		},
    

    Any ideas would be gratefully welcomed…
    Thanks in advance
    J


  • Project Sponsor Module Developer

    @j-ason

    There is a file included in the images folder of the module. It’s called Example.jpg.

    Using the config entry from the repo your entry would look like this:

    {
        module: 'MMM-EasyBack',
        position: 'fullscreen_below',
        config: {
            bgName: "Example.jpg",          // "Example.jpg", the file name of your background image
            videoName: "", 
            youTubeID: "",
            height: "1080px",    // your display's resolution in pixels. Enter in config.js
            width: "1920px",     // your display's resolution in pixels. Enter in config.js
        }
    },
    
    I just tested it and it works as expected.
    

    Dropped my own image into the EasyBack module folder as instructed

    ReadMe says - Background picture files go in the “images” folder inside the MMM-EasyBack module folder.

    Also, the name of your image file is case sensitive so your config entry must have the exact name, case sensitive. (Also in the readMe)

    Let me know how you make out.



  • Hi there and thanks for your reply…

    {
    module: “MMM-EasyBack”,
    position: “fullscreen_below”,
    config: {
    bgName: “Example.jpg”,
    videoName: “”,
    youTubeID: “”,
    height: “1080px”,
    width" “1920px”,
    }

    	},
    

    This is what I have and yet still have config?

    TIA

    J


  • Project Sponsor Module Developer

    @j-ason

    That entry is correct. Something else might be causing the error. You can do two things.

    1. Post your entire config here.using the code block option. It looks like this: </>
    2. start mm using npm start dev. Click the “Elements” tab at the top left of the window that appears.
    3. Report any errors. They will be in red. You may have to scroll.

  • Project Sponsor Module Developer

    @j-ason said in Background Image question ~ EasyBack:

    height: “1080px”,
    width" “1920px”,

    Also, these two values have to match your your displays resolution



  • @Mykle1

    Complete config listed below:

    FYI I did try the nom start dev option too however it said
    npm Error code ENOENT
    npm Error sys call OPEN
    npm Error path /home/pi/package.json
    npm Error errno -2
    npm error enoent Enoent: no such file or directory, open ‘/home/pi/package.json’
    npm error enoent This is related to npm not being able to find a file
    npm error enoent

    npm error A complete log of this run can be run in:
    npm error /home/pi/.npm/_logs/2020 -04-01T22_07_45_756Z-debug.log

    I am sorry if this a simple thing to you however as I have said before I bought a Pi and as I am on lockdown thought… Hey lets give this MM a go and see if I can understand code… Thought / hoped I would have MM up and running using other modules first and then be able to read and learn from there (easy option I know)…

    Thanks again for your time and effort - sorry for delay I am UK time so missed your reply last night

    /* Magic Mirror Config Sample
    *

    */

    var config = {
    address: “localhost”, // Address to listen on, can be:
    // - “localhost”, “127.0.0.1”, “::1” to listen on loopback interface
    // - another specific IPv4/6 to listen on a specific interface
    // - “”, “0.0.0.0”, “::” to listen on any interface
    // Default, when address config is left out, is “localhost”
    port: 8080,
    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”], // Set [] to allow all IP addresses
    // or add a specific IPv4 of 192.168.1.5 :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.1.5”],
    // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    // [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.3.0/28”],

    language: "en",
    timeFormat: 24,
    units: "metric",
    // serverOnly:  true/false/"local" ,
    		     // local for armv6l processors, default 
    		     //   starts serveronly and then starts chrome browser
    		     // false, default for all  NON-armv6l devices
    		     // true, force serveronly mode, because you want to.. no UI on this device
    
    modules: [
    	{
    		module: "alert",
    	},
    	{
    		module: "updatenotification",
    		position: "top_bar"
    	},
    	{
    		module: "clock",
    		position: "top_left"
    	  					
    	},
    	{
    		module: "MMM-Bose-Soundtouch",
    		header: "Music",
    		position: "bottom_right",   
    		config: {          
    		updateInterval: 5, 
    		apiBase: '192.168.0.19',
    	}
    	},
    
    	{		
    		module: "MMM-EasyBack",
    		position: "fullscreen_below",
    		config: {
    		    bgName: "Example.jpg",
    		    videoName: "",
    		    youTubeID: "",
    		    height: "1080px",
    		    width" "1920px",	
    	}
    
    	},
    
    
    
    
    
    	{
    		module: "calendar",
    		header: "Calendar",
    		position: "top_left",
    		config: {
    			calendars: [
    				
    				{
    					symbol: "My Calendar",
    					url: "https://calendar.google.com/calendar/ical/j.asonjmanhart%40gmail.com/private-d0f255d38247687de39d3f4fec66a79f/basic.ics",
    					maximumEntries: 5,
    				},
    				{
    					symbol: "calendar-check-o",
    				        url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/UK_Holidays.ics",
    					maximumEntries: 5
    
    			
    				
    				},
    				
    			],
    		}
    	},
    	{
    		module: "compliments",
    		position: "lower_third",
    			config: {
    			compliments: {
    				morning: [
    					"Have a great day",
    					],
    				afternoon: [
    					"Good afternoon folks",
    					],
    				evening: [
    					"Good evening",
    					]
    	
    		},
    		updateInterval: 30000,
    		remoteFile: null,
    		fadeSpeed: 4000,
    		morningStartTime: 5,
    		morningEndTime: 12,
    		afternoonStartTime: 12,
    		afternoonEndTime: 17
    		}
    },
    	{
    		module:"MMM-OpenmapWeather",
    		position: "top_right",
    		header: "Current Weather",
    		config: {
    			location: "Newport,GB",
    			locationID: "2641598",
    			appid: "8a0a36897340ca635a879e7c7ce77966",
    			colorIcon: true
    		}
    
    	},
    	
    	{
    		module: "weatherforecast",
    		position: "top_right",
    		header: "Weather Forecast",
    		config: {
    			location: "Newport,GB",
    			locationID: "2641598",  //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    			maxNumberOfDays: "7",
    			appid: "8a0a36897340ca635a879e7c7ce77966"
    		}
    	},
    	
    	
    
    	{
    		module: "newsfeed",
    		position: "bottom_bar",
    		config: {
    			feeds: [
    				{
    					title: "BBC UK",
    					url: "http://feeds.bbci.co.uk/news/uk/rss.xml"
    				},
    				
    				
    			],
    			showSourceTitle: true,
    			showPublishDate: true,
    			broadcastNewsFeeds: true,
    			broadcastNewsUpdates: true
    		}
    	},
    ]
    

    };

    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {module.exports = config;}


  • Project Sponsor

    @j-ason said in Background Image question ~ EasyBack:

    {
    module: “MMM-EasyBack”,
    position: “fullscreen_below”,
    config: {
    bgName: “Example.jpg”,
    videoName: “”,
    youTubeID: “”,
    height: “1080px”,
    width" “1920px”,
    }

    I think I found it. It should read width: "1920". You’re missing the : and have an extra ".



  • @bhepler
    You sir / madam are a blooming legend 🙂 🙂 🙂 🙂 🙂 🙂 🙂


  • Project Sponsor Module Developer

    @bhepler

    Thanks hep. I didn’t see that. 👍


Log in to reply