MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Electron failed to install properly



  • Used the auto-installer to install MM2, When i type DISPLAY=:0 npm start i get this error. ```

    magicmirror@2.1.0 start /home/pi/MagicMirror
    > electron js/electron.js
    
    /home/pi/MagicMirror/node_modules/electron/index.js:9
    throw new Error('Electron failed to install correctly, please delete node_modu                                                                                        les/' + path.basename(__dirname) + ' and try installing again')
    ^
    
    Error: Electron failed to install correctly, please delete node_modules/electron                                                                                         and try installing again
      at Object. (/home/pi/MagicMirror/node_modules/electron/index.js:9                                                                                        :9)
      at Module._compile (module.js:570:32)
      at Object.Module._extensions..js (module.js:579:10)
      at Module.load (module.js:487:32)
      at tryModuleLoad (module.js:446:12)
      at Function.Module._load (module.js:438:3)
      at Module.require (module.js:497:17)
      at require (internal/module.js:20:19)
      at Object. (/home/pi/MagicMirror/node_modules/electron/cli.js:3:1                                                                                        6)
      at Module._compile (module.js:570:32)
    
    npm ERR! Linux 4.4.43-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
    npm ERR! node v6.9.4
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! magicmirror@2.1.0 start: `electron js/electron.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.1.0 start script 'electron js/electron.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     electron js/electron.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs magicmirror
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    
    
    Looked around for a fix but could not find one, Electron quick start gave the same error, any ideas?


  • Are you starting your mirror over ssh?

    That would be the only reason to use DISPLAY=:0 npm start



  • Yeah I am



  • Which version of Raspbian are you using?



  • The latest one, Jesse, only downloaded it a couple days ago



  • Jessie or Jessie Lite?



  • Full version of Jessie, not Jessie light



  • When i type “node --version” it says i have V4.0.0 installed which is very outdated, could this be why?



  • @cianoo45 said in Electron failed to install properly:

    When i type “node --version” it says i have V4.0.0 installed which is very outdated, could this be why?

    Nevermind, updated to V7.4 and i still get the same error when running



  • Getting the exact same thing here too - Raspberry Pi3 - any ideas?

    16 error Linux 4.4.34-v7+
    17 error argv “/usr/local/bin/node” “/usr/local/bin/npm” "start"
    18 error node v6.9.4
    19 error npm v3.10.10
    20 error file sh
    21 error code ELIFECYCLE
    22 error errno ENOENT
    23 error syscall spawn
    24 error magicmirror@2.1.0 start: electron js/electron.js
    24 error spawn ENOENT
    25 error Failed at the magicmirror@2.1.0 start script ‘electron js/electron.js’.

    I had tried using the latest node too - I downgraded to v6.9.4 just on the off chance it was a versioning thing but as you can see no go.