MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

[MMM-Buttons] An unhandled error occurred inside electron-rebuild



  • Anyone now why?

    > electron-rebuild -e ../../node_modules/electron
    
    An unhandled error occurred inside electron-rebuild
    Unable to find electron-prebuilt's version number, either install it or specify an explicit version
    
    Error: Unable to find electron-prebuilt's version number, either install it or specify an explicit version
        at _callee$ (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/electron-rebuild/lib/cli.js:74:17)
        at tryCatch (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/babel-runtime/node_modules/regenerator-runtime/runtime.js:63:40)
        at Generator.invoke [as _invoke] (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/babel-runtime/node_modules/regenerator-runtime/runtime.js:337:22)
        at Generator.prototype.(anonymous function) [as next] (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/babel-runtime/node_modules/regenerator-runtime/runtime.js:96:21)
        at Generator.tryCatcher (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/bluebird/js/release/util.js:16:23)
        at PromiseSpawn._promiseFulfilled (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/bluebird/js/release/generators.js:97:49)
        at /home/pi/MagicMirror/modules/MMM-Buttons/node_modules/bluebird/js/release/generators.js:201:15
        at Object. (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/electron-rebuild/lib/cli.js:197:4)
        at Module._compile (module.js:571:32)
        at Object.Module._extensions..js (module.js:580:10)
        at Module.load (module.js:488:32)
        at tryModuleLoad (module.js:447:12)
        at Function.Module._load (module.js:439:3)
        at Module.runMain (module.js:605:10)
        at run (bootstrap_node.js:420:7)
        at startup (bootstrap_node.js:139:9)
    
    

  • Module Developer

    @FlorianRD

    Did you run npm install in the MMM-Buttons folder?


  • Moderator

    @FlorianRD You need to be on Magic Mirror versions 2.1.0 or higher (i.e. develop branch).

    Edit: What MagicMirror version are you on? 2.1.0? When you navigate from the MMM-Buttons folder to ../../node_modules you should end up in a folder with an electron folder. If there is only a electron-prebuilt folder, it should be possible to fix the issues by upgrading MagicMirror to 2.1.0.