Help customising my mirror



  • Hi guys, to start, I’d like to say that I am not experienced with this stuff in any sort of way so whatever is explained to me would have to be in the simplest way possible.

    Ok, so I have gotten up to the step where I get to customise how I want my mirror to look. I have tried many times but failed. It says in the tutorial that I have to ‘Duplicate config/config.js.sample to config/config.js’ but I don’t know what that means. When I enter ‘config/config.js.sample’ to the terminal while under the ‘cd ~/MagicMirror’ directory, it says permission denied. I don’t know what this means and I don’t know a way around it.

    Could someone please explain to me how to customise my mirror? I have been stuck on this for over 2 weeks. Thanks!


  • Module Developer

    @PhilsterM9 in Magicmirror directory, enter config directory via cd config
    While in the config directory type cp config.js.sample config.js

    After that type dir you should now see two files listed, one config.sample.js and one config.js

    Now you have a working config file and should be able to start the magicmirror


  • Module Developer

    @PhilsterM9

    I was just like you a few weeks ago. I didn’t know a thing about this, or coding. A complete noob, as they say. My suggestion, because it helped me, is, don’t do your editing in the terminal. Do it in the graphical user interface (GUI). Navigate your desktop as you would on a PC with Windows or a Mac’s Finder.

    Click on File Manager (the folder at the top left of your desktop, usually)
    Double click the MagicMirror folder
    Double click the config folder
    Right click the config.js.sample file - select Copy
    Right click again somewhere else in that same window - select Paste
    Rename the file to config.js and click the Rename button
    The new config.js file that you just pasted is now your working config file for MagicMirror
    Double click it and it should open in a text editor.

    This is one of the places where you will customize your MM. It’s actually good enough to run your MM, although it will only show some of the modules but you’ll be encouraged by the fact that it is at least working. Every module folder has a ReadMe file that instructs you on what to add to your config.js file to get that module up and running.

    I think that’s good for now. If you want to run MM right now to see how your new config.js is working you will have to go back to the terminal. Do this:

    Open a new terminal
    type cd MagicMirror
    then type npm start

    Sit back and watch the magic happen. When you calm down after a minute or two of watching your MM actually working and you want to quit MM, press the Option key on your keyboard. Select QUIT from File menu that appears, top left of your screen



  • @Mykle1 Hi there, thanks for the time you took to reply.

    I did as you have written in your own instructions and when I try to configure my mirror through the read me file, it still won’t work. I am not sure what is happening. I am trying to start off by adding an analog clock instead of digital but it will not let me for the life of me. The trouble is that I know that I can change the file and make it work because I can tried changing the clock to sit on the right side instead of the left and it works.

    I am a noob but this is really frustrating me. Thanks for helping.


  • Moderator

    Then please post the content of your config.js file, however please remove passwords, private calendar links and apikeys


  • Module Developer

    @PhilsterM9 said in Help customising my mirror:

    The trouble is that I know that I can change the file and make it work because I can tried changing the clock to sit on the right side instead of the left and it works.

    The simplest answer would be to add this under “position” in the clock section of your config.js file. It should look like this now:

    module: ‘clock’,
    position: ‘top_left’
    displayType: “digital”, // options: digital, analog, both

    Change the displayType to “analog” “digital” or "both"
    Save your config.js file and restart MM



  • @Mykle1 that answer is not correct, module config options have to be in the object config

    module: 'clock',
    position: 'top_left',
    config: {
      displayType: 'digital'
    }
    

  • Module Developer

    @strawberry-3.141 said in Help customising my mirror:

    @Mykle1 that answer is not correct, module config options have to be in the object config

    Yup, you’re right. In my haste to answer, because I was pressed for time this morning, I mistakenly omitted that. My bad. Thanks for catching that.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.