Splash Screens/No Signal



  • Hi,

    I’ve searched through the forums and not managed to find an answer. I’m looking to pick up a second hand monitor (they seem cheaper than TVs) and I’d like to use a PIR sensor to turn the monitor on and off. However, when the HDMI output of the Pi is turned off, won’t the monitor display a “No SIgnal” message or even a company splash screen?

    Can anyone confirm whether this is a genuine concern and, if so, how to avoid it?

    Thanks for your help,
    Steve



  • @steve23p9835908 depends on your monitor. For most, the pi sends a “power off” signal, and you get no message.

    Really, you gotta play worth the parts you have to see how it works.



  • @steve23p9835908
    Hi Steve,

    did you find one?
    I’ve got the same problem …

    Thanks MyMirror



  • I used a BenQ and it had the option to disable the splashscreen. I’d suggest using Google for the monitor you’re looking at + “disable splash screen” or something like that, quite a lot of monitors have these options. I’d also suggest checking the power consumption.

    I used a PIR sensor to switch the monitor independently from the RasPi while the RasPi is running 24/7. Mainly because my RasPi is collecting data every 2 hours and writing it to a JSON that I want to be updated without interuption. The other reason was the screens power consumption in standby (I’m not at home for at least 10 hours every day and sleeping ~ 7 hours, so that’s min 17 hours standby every day) and the screen takes ~ 3 or 4 seconds to turn on while the RasPi takes quite a bit longer to start.

    Just be careful when selecting and setting up that PIR sensor with a switch for the monitor, not a lot are suitable for that power consumption and load and setting it up means working with the 220 V cable (or whatever voltage your country might have) – if you’re not sure what needs to be done, let a professional handle that. (Trust me, I learned the hard way …)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.