MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-cryptocurrency - v1.4



  • @ArkantosArk Very strange.
    Same module configuration is working here, even if I set 1h.

    {
      module: "MMM-cryptocurrency",
      position: "bottom_bar",
      config: {
        currency: ['ethereum', 'bitcoin'],
          conversion: 'EUR',
          displayType: 'detail',
            headers: ['change24h', 'change1h']
      }
    }
    

    Is it possible that aren’t conflict with other modules?
    In any case, if you cannot fix, try to re-download module from repository and then re-add in your configuration.
    Let me know if something changes.



  • Re: MMM-cryptocurrency - v1.1
    @matteodanelli great module. I works pretty fine. Thank you for this.

    At the moment we have 3 options to view the change of the currency in 1h, 24h and 7d.
    Can you add an option to view the change since the purchase value?

    Or how I can do this by myself?

    BR



  • @jimador Hi!
    Unfortunately, it’s not easy to select a custom starting date, because I use an external service which provides me only that history.
    Tracking myself the currency change is expensive and I’ll not do in the next future.
    But, if you know some web services able to do that I’m really happy to implement this feature 🙂



  • @matteodanelli Hi have reinstalled the module and keeps showing the same error on the logs:

    modules/MMM-cryptocurrency//MMM-cryptocurrency.js @68: TypeError: undefined is not a function (evaluating ‘this.config.headers.includes(‘change1h’)’)

    It seems that it can be an issue on line 68 on that file. If I copy and paste the content of the file on JSHint.com, it shows me that there is an error on some lines:

    0_1504468978573_Captura de pantalla 2017-09-03 a las 21.02.11.png

    I would love it to have this module on detail mode, but it seems that is only working properly in logo mode for now.



  • @ArkantosArk Hey,
    I make a bug fix where you outlined some problems. You can checkout updated code from repository.

    Now you should have the module working in both configuration.
    Let me know.

    Thank you!



  • @matteodanelli Hi!

    I can see your update and now JShint doesn’t find any issues. However I still have the same exact issue as my previous post. Can this be a browser related issue? I am using Midori instead of Chrome (cause I’m implementing everything on a Raspberry pi 1).

    Anyway thanks a lot for correcting those bugs, I’m sure that would help somebody with the same issue!


  • Project Sponsor Module Developer

    @ArkantosArk Yes, midori doesn’t support ES6 and the module makes use of it. Try to run it and access it via a browser on another machine for testing purposes it should probably work.



  • @ArkantosArk As @strawberry-3-141 mentioned, I use ES6 in the module and so some old browsers aren’t working. Midori uses an old version of the web engine, but I know that it’s the best browser on the RPi1.

    However, I tried to replace in my module a function which creates a problem. I am not sure to have solved totally the problem because I cannot test on Midori.
    I’ve updated the module so you can test it now, hoping that it’s working, or at least it shows less problems 🙂

    Let me know!



  • @matteodanelli Now it’s working! thanks a lot for this I feel really privileged!. Thanks for taking the effort to update the module just for this.



  • Thank you for this module.
    In order to add a new coin, I’ve added into sparklineIds the id, eg. chainlink: 1975,
    ran an nmp install into the MMM-cryptocurrency module, but still no luck,
    sparklineId is correct, am I missing something?
    Thanks in advance.


Log in to reply