MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

[MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras



  • @jngo said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    tried to comment out the W & H, it still did the same issue.

    Actually I was interested in the --win coordinates from the pm2 log in this case.
    If the same, then it means that uncommented is right and the values are being taken from the config.js parameters.
    It looks it can be uncommented.

    One last suggestion:

    Either in the MM-RTSPStream.css or your /home/pi/MagicMirror/css/custom.css:

    .MMM-RTSPStream .innerWrapper {
      position: relative;
      width: 468px; /* Video width + 18px
      height: 253px;
      border-style: none;
      display: inline-block;
      text-align: center;
    }
    

    Regarding

    How do I increase the size of the fonts used in the MM?
    you will have to ask this in a separate topic.
    Best is to change things in the custom.css.
    I only made changes regarding the width of some regions.



  • This post is deleted!


  • Some tips/improvements.

    I’ve disabled the sound in the omx-stream by adding the arguments “-n”,"-1", in the node_helper.js

     payload.forEach(s => {
                var args = ["--live", "--video_queue", "4", "--fps", "30","-n","-1",
                    this.config[s.name].url
                ];
    
    

    I had problems with the omx-streams (i have three) not restarting correctly. So instead of stopping the processes and then starting, i’ve changed the command to restart.

                    for (var proc in list) {
                        if ("name" in list[proc] && namesM.indexOf(list[proc].name) > -1) {
                            if ("status" in list[proc].pm2_env && list[proc].pm2_env.status === "online") {
                                console.log(`PM2: ${list[proc].name} already running. Stopping old instance...`);
    //                            pm2.stop(list[proc].name, errCB);
                                pm2.restart(list[proc].name, errCB);
                            }
                        }
                    }
    
    


  • what is the right process to follow for a new installation? the github page or the explanation on page 17?



  • I have RTSP enabled on my Wyze camera, but nothing displays with this module. The URL it provides is in the format:
    rtsp://USER:PASSWORD@ADDRESS/live

    I noticed that it doesn’t provide the actual file extension such as .mov so I’m wondering if that’s preventing this from working for me.



  • @twosquirrels

    Can you try this ?

    $ omxplayer --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win "0 0 480 320" rtsp://USER:PASSWORD@ADDRESS/live
    

    To see if it works standalone.

    I forgot if a license is needed for the camera stream, but to know if a license is present:

    $ vcgencmd codec_enabled MPG2
    


  • Started at page 17 and running on the latest develop branch and trying to use omxplayer. Open GL fake is running with 128. Using VLC on a windows PC I’m able to get the RTSP stream working.

    In VLC I chose network stream use the URL
    rtsp://admin:******@192.168.200.4:554/cam/realmonitor?channel=1&subtype=0
    I do have select ‘Active Transcoding’ and use Video -H.264 + MP3 (MP4)

    When I run it on MagicMirror I get this:
    0_1557872101244_IMG_0481.jpg

    It’s an Amcrest Camera. I’m able to test using the “Big Buck Bunny” and that works great.



  • @0YXmEQ
    Update: This issue appears specific to my Amcrest Camera. I’m able to stream my Arecont Camera.

    On that not my Arecont Camera has 4 lenses. How could have to RTSP stream windows side by side? Each showing one lense with no border?

    rtsp://192.168.200.10/h264.sdp2?res=full&doublescan=0&ssn=466
    rtsp://192.168.200.10/h264.sdp3?res=full&doublescan=0&ssn=467



  • Im trying to use the VLC player on the “develop” branch code. Im running into issues with VLC. If I set my localplayer to omxplayer then everything works fine. If I change it to “vlc” I dont not get a picture. Is there something else I need to change for it to work? Thanks!



  • @SH20192 said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    Im trying to use the VLC player on the “develop” branch code. Im running into issues with VLC. If I set my localplayer to omxplayer then everything works fine. If I change it to “vlc” I dont not get a picture. Is there something else I need to change for it to work? Thanks!

    disregard. didnt realize I needed to reload the node modules. seems to have fixed the issue.