MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

[MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras



  • @bill22

    The last output actually looks good.
    Processes are there.
    Do they remain present after a few minutes, with same PID’s ?

    Can you try this again using quotes around the --win parameter ?

    $ /usr/bin/omxplayer --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win '351 968 703 1210' rtsp://192.168.178.1:554/?avm=1&freq=394&bw=8&msys=dvbc&mtype=256qam&sr=6900&specinv=0&pids=0,16,17,18,20,266,593,594,595,598,1801,1802,1803
    

    It can be that a mpeg2 license is necessary.
    I know that for satellite TS streams it is.
    http://www.raspberrypi.com/mpeg-2-license-key/

    When you stream it via VLC Player, you can see under Media Information - Codec Details what codec is being used.



  • @evroom

    not sure if i can check this correctly with the processes but if i run the test file (Big Bunny) it runs for minutes…

    tried it with quotes around the win parameter:

    pi@raspberrypi:~ $ $ /usr/bin/omxplayer --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win '351 968 703 1210' rtsp://192.168.178.1:554/?avm=1&freq=394&bw=8&msys=dvbc&mtype=256qam&sr=6900&specinv=0&pids=0,16,17,18,20,266,593,594,595,598,1801,1802,1803
    [1] 1563
    [2] 1564
    [3] 1565
    bash: $: Kommando nicht gefunden.
    [4] 1566
    [5] 1567
    [6] 1568
    [7] 1569
    [1]   Exit 127                $ /usr/bin/omxplayer --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win '351 968 703 1210' rtsp://192.168.178.1:554/?avm=1
    [2]   Fertig                  freq=394
    [4]   Fertig                  msys=dvbc
    [5]   Fertig                  mtype=256qam
    [6]-  Fertig                  sr=6900
    

    I am also going to check it out with the license as VLC is showing MPEG 1/2 (mpgv) as codec…



  • @evroom

    MPG2 license is enabled now.

    There is a difference now as the grey box from RTSP Stream module contains a Pause symbol (autostart is enabled) when moving the mouse over it…and becomes a play button when i click on it.

    I have also adapted the frame rate and size towards the parameters shown in the VLC player detail window.

    Any other idea what i could try…?



  • @bill22
    You have to remove the second $ in the command.
    This $ in my examples is just to say to run it from the the command line.



  • @bill22

    You try to add --genlog after the omxplayer command, like
    omxplayer --genlog --avdict rtsp_transport:tcp ............
    Then check the omxplayer.log, normally located under the directory where you started the command.
    Or find it using sudo find . -name omxplayer.log.



  • @bill22

    Just a disclaimer.
    I do not use this module any more for my stream (a webcam using h.265).
    See first post on this page:
    https://forum.magicmirror.builders/topic/2743/mmm-rtspstream-video-streaming-from-live-feeds-security-cameras/262?page=27

    I could try to set it up again for a sat stream.



  • @evroom

    Thanks and i entered the command in the right way again:

    pi@raspberrypi:~ $ /usr/bin/omxplayer --genlog --avdict rtsp_transport:tcp --live --video_queue 4 --fps 30 --win '351 968 703 1210' rtsp://192.168.178.1:554/?avm=1&freq=394&bw=8&msys=dvbc&mtype=256qam&sr=6900&specinv=0&pids=0,16,17,18,20,266,593,594,595,598,1801,1802,1803
    [1] 27791
    [2] 27792
    [3] 27793
    [4] 27794
    [5] 27795
    [6] 27796
    [7] 27797
    [3]   Fertig                  bw=8
    [4]   Fertig                  msys=dvbc
    

    Log:

    20:16:28 T:11869916 DEBUG: DllBcm: Using omx system library
    20:16:29 T:12283107 DEBUG: DllOMX: Using omx system library
    20:16:29 T:12283969 DEBUG: DllAvFormat: Using libavformat system library
    20:16:29 T:12285949 WARNING: Failed to acquire D-Bus name ‘org.mpris.MediaPlayer2.omxplayer’
    20:16:29 T:12286105 WARNING: DBus connection failed, trying alternate
    20:16:29 T:12287974 DEBUG: DBus connection succeeded



  • @evroom said in [MMM-RTSPStream] - Video Streaming from Live Feeds & Security Cameras:

    https://forum.magicmirror.builders/topic/2743/mmm-rtspstream-video-streaming-from-live-feeds-security-cameras/262?page=27

    @evroom Thanks a lot for your support especially as you are not using the module actually anymore…

    Am i right that the RTSPStream module is the best option/only one i could use for my case?



  • @bill22

    I think I have the same issue as you:
    0_1562531719799_RTSP_play_button.png
    It would be the best option, if it would work. 🙂

    As a workaround for my IP cam issue, I use omxplayer as a separate process.
    It is an overlay on top of your screen anyway.

    For you, it is first priority to get your stream using omxplayer working, outside of MM
    So disable the module and restart MM.

    module: "MMM-RTSPStream",
        disabled: true,
        :
        :
    

    Then we take it from there.

    Can you confirm that your stream is MPEG-4 (vlc player media information) ?



  • yes, that would be great having the module just working 🙂

    Picture looks same as on mine…

    Module is disabled.

    Just checked again in VLC.
    Codec: MPEG-1/2 Video (mpgv)