Failure of v2.2.0



  • I have 4 MM in my home all running Pi 3. I started with one of my basic projects and tried an upgrade as suggested. Could not get it to work. Did a fresh install and it worked for 24 hours before it crashed.

    Now when I try a fresh install on a Stretch-Lite it crashes when trying to install the program.

    root@clock:/home/carltonb# curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh | bash
    
    $$\      $$\                     $$\           $$\      $$\ $$\                                          $$$$$$\
    $$$\    $$$ |                    \__|          $$$\    $$$ |\__|                                        $$  __$$\
    $$$$\  $$$$ | $$$$$$\   $$$$$$\  $$\  $$$$$$$\ $$$$\  $$$$ |$$\  $$$$$$\   $$$$$$\   $$$$$$\   $$$$$$\  \__/  $$ |
    $$\$$\$$ $$ | \____$$\ $$  __$$\ $$ |$$  _____|$$\$$\$$ $$ |$$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  __$$\  $$$$$$  |
    $$ \$$$  $$ | $$$$$$$ |$$ /  $$ |$$ |$$ /      $$ \$$$  $$ |$$ |$$ |  \__|$$ |  \__|$$ /  $$ |$$ |  \__|$$  ____/
    $$ |\$  /$$ |$$  __$$ |$$ |  $$ |$$ |$$ |      $$ |\$  /$$ |$$ |$$ |      $$ |      $$ |  $$ |$$ |      $$ |
    $$ | \_/ $$ |\$$$$$$$ |\$$$$$$$ |$$ |\$$$$$$$\ $$ | \_/ $$ |$$ |$$ |      $$ |      \$$$$$$  |$$ |      $$$$$$$$\
    \__|     \__| \_______| \____$$ |\__| \_______|\__|     \__|\__|\__|      \__|       \______/ \__|      \________|
                           $$\   $$ |
                           \$$$$$$  |
                            \______/
    
    Updating packages ...
    Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists... Done                      
    Installing helper tools ...
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    build-essential is already the newest version (12.3).
    curl is already the newest version (7.52.1-5+deb9u3).
    git is already the newest version (1:2.11.0-3+deb9u2).
    unzip is already the newest version (6.0-21).
    wget is already the newest version (1.18-5+deb9u1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Check current Node installation ...
    Node.js is not installed.
    Installing Node.js ...
    
    ## Installing the NodeSource Node.js v6.x repo...
    
    
    ## Populating apt-get cache...
    
    + apt-get update
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Reading package lists... Done
    
    ## Confirming "stretch" is supported...
    
    + curl -sLf -o /dev/null 'https://deb.nodesource.com/node_6.x/dists/stretch/Release'
    
    ## Adding the NodeSource signing key to your keyring...
    
    + curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
    OK
    
    ## Creating apt sources list file for the NodeSource Node.js v6.x repo...
    
    + echo 'deb https://deb.nodesource.com/node_6.x stretch main' > /etc/apt/sources.list.d/nodesource.list
    + echo 'deb-src https://deb.nodesource.com/node_6.x stretch main' >> /etc/apt/sources.list.d/nodesource.list
    
    ## Running `apt-get update` for you...
    
    + apt-get update
    Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
    Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Get:3 https://deb.nodesource.com/node_6.x stretch InRelease [4,635 B]
    Get:4 https://deb.nodesource.com/node_6.x stretch/main armhf Packages [1,006 B]
    Fetched 5,641 B in 2s (2,261 B/s)    
    Reading package lists... Done
    
    ## Run `apt-get install nodejs` (as root) to install Node.js v6.x and npm
    
    Reading package lists... Done
    Building dependency tree        
    Reading state information... Done
    The following NEW packages will be installed:
      nodejs
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 8,790 kB of archives.
    After this operation, 41.1 MB of additional disk space will be used.
    Get:1 https://deb.nodesource.com/node_6.x stretch/main armhf nodejs armhf 6.12.3-1nodesource1 [8,790 kB]
    Fetched 8,790 kB in 2s (3,995 kB/s) 
    Selecting previously unselected package nodejs.
    (Reading database ... 63007 files and directories currently installed.)
    Preparing to unpack .../nodejs_6.12.3-1nodesource1_armhf.deb ...
    Unpacking nodejs (6.12.3-1nodesource1) ...
    Setting up nodejs (6.12.3-1nodesource1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Node.js installation Done!
    Cloning MagicMirror ...
    Cloning into 'MagicMirror'...
    remote: Counting objects: 8976, done.
    remote: Compressing objects: 100% (8/8), done.
    remote: Total 8976 (delta 3), reused 3 (delta 1), pack-reused 8967
    Receiving objects: 100% (8976/8976), 11.48 MiB | 7.35 MiB/s, done.
    Resolving deltas: 100% (5077/5077), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    npm WARN deprecated coffee-script@1.10.0: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
    npm WARN prefer global coffee-script@1.10.0 should be installed with -g
    npm WARN prefer global jsonlint@1.6.2 should be installed with -g
    
    > uws@0.14.5 install /root/MagicMirror/node_modules/uws
    > node-gyp rebuild > build_log.txt 2>&1 || exit 0
    

    Any thoughts
    Carltonb



  • There has been known issues with Stretch in general… I would go back to Jessie and try it again…



  • Pardon my ignorance but where would I find Jessie Lite. On the Pi website download all I am offered is this RASPBIAN STRETCH LITE or the version with the desktop.
    carltonb



  • After a bunch of searching I finally found it at https://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2017-07-05/
    Had to do a lot of digging. Seems it is outdated by strech.
    Thanks


  • Module Developer

    @carltonb said in Failure of v2.2.0:

    Had to do a lot of digging. Seems it is outdated by strech.

    It is outdated by Stretch, but as @cowbowsdude stated, there have been some issues with Stretch and MM. With a full version of Jessie, you won’t encounter any problems that are OS related. Does it really matter to you what OS you use as long as it runs MM without issue? Lite versions can present their own set of problems during installation.

    My recommendation is this version of Jessie
    http://downloads.raspberrypi.org/raspbian/images/raspbian-2017-07-05/



  • @Mykle1 Thanks, I will give it a try. Interesting that I have used the stretch version on 4 setups with no problem. Must be with the new version 2.2 that it has issues.
    I will let you know the results.
    carltonb


  • Module Developer

    @carltonb said in Failure of v2.2.0:

    Must be with the new version 2.2 that it has issues.

    That is entirely possible. Good luck, mate!

    Peace



  • @carltonb No ignorance…it’s okay to ask questions! :)



  • @Mykle1 Since as you said the OS makes no difference to me. So …
    This is the file I d/l
    2017-07-05-raspbian-jessie.zip 05-Jul-2017 13:05 1.5G
    Install went fine, but again crashed when I tried to use this command. It crashes at the same point every time. See the file generation after I start the installer in the first post.

    Get and install MagicMirror with the Automatic Installer:

    curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh | bash

    Might there be something wrong script that is trying to install it.
    Is there another way to install it without using the Automatic Installer script.

    carltonb


  • Module Developer

    @carltonb said in Failure of v2.2.0:

    Is there another way to install it without using the Automatic Installer script.

    https://forum.magicmirror.builders/topic/5274/how-to-manually-install-mm-on-your-pi-for-absolute-beginners


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.