MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Mirror turning black after a while

  • Project Sponsor Module Developer

    I have a problem after the latest update (v 2.2.2). After a few hours (7h one day, 12h another day etc.) my mirror goes completely black. I can show the mirror from other devices though and I can access MMM-RemoteControl. If restarting MM, all modules reappear again, only to fail a few hours again.

    I have checked the logs (.pm2/logs/*.log) and nothing is reported about this.
    I’m running a pi3 with Jessie 8.0.
    The mirror has been running ok for several months before this and all previous updates have gone ok.

    My update procedure was this:

    1. MagicMirror/> git pull && npm install
    2. Got error “Electron failed to install correctly, please delete node_modules/electron and try installing again”
    3. Deleted electron folder.
    4. Updated npm (sudo npm install -g npm) just to make sure.
    5. MagicMirror/> npm install (electron was reinstalled).
    6. No errors while updating or running.

    I’m running these modules:

    • default/alert
    • default/updatenotification
    • default/clock
    • default/calendar
    • MMM-MyCommute
    • MMM-RemoteControl
    • MMM-SkolMaten (x2)
    • MMM-ResRobot

    Any ideas?

  • Project Sponsor Module Developer


    Very odd. Does the display you are using have a status light? Sounds as if the display loses the video signal then fails to reacquire it. In which case, the status light would be yellow. Can you temporarily connect the display to another PC and to see if it exhibits the same behavior? A PIA, I know, but it would eliminate the possibility that the display is failing.

    Or, there are commands that you could try to force the display on (or off) to see how it responds. Those commands escape me right now but they are on this forum somewhere.

    Wish I could have been more help. Good luck.

  • Project Sponsor Module Developer

    Thanks. I’m pretty sure the monitor is on, because if I connect a keyboard I can start a terminal and it doesn’t look like it has been down in sleep mode (should take longer time to wake). I’ve also tried to turn off/on screen with MMM-RemoteControl just to make sure, but no luck. I’ll double check the status light when the error occurs again.

  • @retroflex
    I also encounter this problem episodically. Magic mirror works normally but no module appears on the screen a simple ctrl + R (reload) is enough to refresh and make reappear modules.

  • Project Sponsor Module Developer

    Did you have the same error on the old version or did it appear with the latest?

  • Module Developer

    Is there any kind of “sleep” mode on the system itself?
    The node log probably doesn’t detect what’s going on but maybe the console log would show (unfortunately, it’s reset when the browser window is refreshed). I’d start MM in dev mode and wait for the crash, then check the browser’s console log.

  • Project Sponsor Module Developer

    @doubleT Thanks for the tip! I will try dev mode and report back.

  • @retroflex said in Mirror turning black after a while:

    Did you have the same error on the old version or did it appear with the latest?

    it is true that this is happening since the last version.
    I did not pay much attention to this because it was during an attempt to install a module that caused me a lot of trouble. I thought it was just that.
    As I told you, it’s still very episodic, it must have been more than two days since it did not happen.


  • Hello All, is this issue fixed? I still have this issue and I get back the screen only by ctrl + R. I am experiencing this issue only after the recent update.

  • Project Sponsor Module Developer

    @bimalnair I haven’t done any more research. But now I have started in dev mode and will see if the console log says anything useful. But it usually takes some hours before my freezes, so I will know later today (hopefully).

    Another test is to remove module by module to see if a certain module is causing problems. Or the opposite, start with only one module and see if it will freeze. Can you check which modules we share? Maybe we can narrow it down a bit.

Log in to reply