Getting the MagicMirror full-screen resolution



  • Hi!

    Total noob here, trying to set up the interface for MagicMirror. So far everything has been pretty straightforward, except for one problem:

    The resolution doesn’t really go full-size. Check out this Image:
    0_1516030593357_Snapchat-1441988271.jpg

    Its fit correctly to the left and bottom size, but top and right are not being used. I set the MM css to white background to demonstrate what it looks like in the picture

    I’ve been playing around with boot/config and trying different overscan options, and disabling overscan but i’m not really sure this is the issue at all… ?

    The monitor is an LG W2040s and according to the TVService the preferred hdmi mode was 83 (which im running in the boot/config)

    The monitor is running VGA to HDMI (Via adapter), and i had to force HDMI to boost 11 to remove some flickering (monitor turning on and off after a while) as well…

    Any help appreciated!

    Best regards,
    Peter



  • @petrpls said in Getting the MagicMirror full-screen resolution:

    Any help appreciated!

    You need to edit your config file ( /boot/config.txt) see this thread for details.



  • @pjkoeleman I saw that forum post a while back, and tried both manually overscaning to get the black board out, and also running disable_overscan 1 but it still ends up the same. This is my current boot/config

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=10
    #overscan_right=-1000
    #overscan_top=-512
    #overscan_bottom=-256
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=1
    hdmi_mode=83
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=1
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    config_hdmi_boost=11
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    display_rotate=1
    avoid_warnings=1
    
    Any thoughts on what could be missing?
    


  • Does your monitor itself allow adjustment?



  • have u tried sudo raspi-config ?
    Go to advanced and then to resolution.



  • @doubleT said in Getting the MagicMirror full-screen resolution:

    There’s just one option for “resolution” on the physical monitor settings, and that is to move the “frame”. i.e i can make the white drawed surface move around, but i can’t reduce the black frame… :(



  • @cruunnerr said in Getting the MagicMirror full-screen resolution:

    have u tried sudo raspi-config ?
    Go to advanced and then to resolution.

    I tried but it didnt make a difference… i guess its like setting the mode and stuff in the boot/config but through the interface instead ? :|



  • Otherwise first connect directly via HDMI and see what kind of image this gives.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.