MMM-Assistant (updated) -- Your voice to the world!



  • I have now updated to the Google Assistant and MM Voice Control module: MMM-Assistant. AFAICT it all works now. So now we can focus on improvements, but any help or testing is always appreciated.

    0_1522235586250_firefox_2018-03-28_14-12-24.png

    PS. I am not original developer of this module, I just help maintaining it.


  • Module Developer

    @E3V3A

    I’m sure you just made a lot of people happy. Well done, sir. 🙂



  • @Mykle1 Thank you! Not sure there will be that many… But now I can focus to also add Alexa!



  • @E3V3A said

    But now I can focus to also add Alexa!

    Thanks very much for your work on this, and will, along with many others, really look forward to seeing Alexa actually working on my Mirror.

    Thanks again.


  • Module Developer

    @E3V3A said in MMM-Assistant (updated) -- Your voice to the world!:

    Thank you! Not sure there will be that many… But now I can focus to also add Alexa!

    You are welcome, sir. Oh, I think there will be more and more once the word gets out. And once you’ve integrated Alexa, you’ll be famous. 🙂



  • @Mykle1 said

    @E3V3A

    once you’ve integrated Alexa, you’ll be famous. 🙂

    I’m unsure if @E3V3A knows the grief and suffering so many have endured trying to install Alexa, by the book, word by word, and failed to get it to work, and/or it failed to work shortly afterwards?

    So yeah, I’m sure there are quite a lot of people who would agree that @E3V3A Will be famous 😉



  • @E3V3A Wow, thank you for contributing!

    I installed a fresh copy using the instructions. Not all instructions are completely up-to-date at the moment but I think I found where everything is located. Keys and such now go into the assets folder and I found a google-auth.js in the scripts folder. Unfortunately when i run

    node google-auth.js
    

    it reports the following error:

    /home/pi/MagicMirror/modules/MMM-Assistant/node_modules/google-assistant/components/auth.js:18
    throw new Error(‘Missing “keyFilePath” from config (should be where your JSON file is)’);

    The same error is given when running google-auth2.js

    Any ideas how I should proceed?


    v9.10.1
    5.8.0
    Linux MagicMirror 4.14.30-v7+ #1102 SMP Mon Mar 26 16:45:49 BST 2018 armv7l GNU/Linux
    No LSB modules are available.
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 9.4 (stretch)
    Release: 9.4
    Codename: stretch



  • @drftg Hi! Did you clone that in the last 20 hours? I made a lot of changes the last few days…
    I still did not test that script since my changes. You’re the one now!

    Please post:

    • the content of script file
    • the MM config (with only your MMM-Assistant part)
    • the output of ls -al ./assets (from this module directory)


  • @drftg
    Try this:

    cd ./assets
    # check if you already have an access token file (google-access-tokens.json)?
    ls -al 
    # if YES, then try:
    chmod 666 google-access-tokens.json
    cd ../scripts
    node google-auth.js
    # if not OK, then try:
    cd ..
    node ./scripts/google-auth.js
    # if not OK, then try to edit the script file, and remove one "dot" from the locations to: 
    # "./assets/google-access-tokens.json" and try to run again from base module location.
    # if not OK, IDK and we try something else
    


  • Can this module be worked with by NOT using Google functionallity?
    I just want to control my mirror modules…
    Thanks