MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

ioBroker MagicMirror Module





  • @GermanBluefox

    Hello,

    i just installed the module and it works 🙂 so far so good ^^

    The only thing is, that no icons appear. Any idea?

    0_1538556432738_Bildschirmfoto 2018-10-03 um 10.46.52.png

    {
              disabled: false,
              module: 'MMM-ioBroker',
              position: 'top_center',
              config: {
                host: '192.168.x.x',
                port: '8082',
                https: false,
                devices: [
                    { name: "Oelstand",
                      deviceStates: [
                                        { id: "mqtt.0.Oeltank.Oelstand", icon: "fa fa-oil-can", suffix: " L" },
                                    ]
                    },
                    { name: 'Oelpreis',
                      deviceStates: [
                                        { id: 'javascript.0.Heizoel.Ist.Price', icon: 'fa fa-euro-sign', suffix: ' €/100L' },
                                     //   { id: 'avascript.0.Heizoel.Ist.Date',    icon: 'fa clock',    suffix: '' }
                                    ]
                    },
                    { name: 'Wohnzimmer',
                      deviceStates: [
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.setpoint', icon: 'wi wi-thermometer', suffix: '°' },
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.valve', icon: 'wi wi-thermometer', suffix: ' %' },
                                    ]
                    },
                    { name: 'Esszimmer',
                      deviceStates: [
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.setpoint', icon: 'wi wi-thermometer', suffix: '°' },
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.valve', icon: 'wi wi-thermometer', suffix: ' %' },
                                    ]
                    },
                    { name: 'Kueche',
                      deviceStates: [
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.setpoint', icon: 'wi wi-thermometer', suffix: '°' },
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.valve', icon: 'wi wi-thermometer', suffix: ' %' },
                                    ]
                    },
                    { name: 'Schlafzimmer',
                      deviceStates: [
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.setpoint', icon: 'wi wi-thermometer', suffix: '°' },
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.valve', icon: 'wi wi-thermometer', suffix: ' %' },
                                    ]
                    },
                    { name: 'Bad',
                      deviceStates: [
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.setpoint', icon: 'wi wi-thermometer', suffix: '°' },
                                        { id: 'maxcube.0.devices.thermostat_XXXXX.valve', icon: 'wi wi-thermometer', suffix: ' %' },
                                    ]
                    },
                  ]
              }
            },
    


  • @GermanBluefox ,

    Thanks for this module it is a great thing, unfortunately it seems to be not working with modbus values.

    {
          module: 'MMM-ioBroker',
          position: 'bottom_bar',
          config: {
            host: '192.168.178.xx',
            port: '8087',
            https: false,
            devices: [
                { name: 'Pufferspeicher',
                  deviceStates: [
                                    { id: 'modbus.0.inputRegisters.12288_puffer_füllung',       icon: 'wi wi-thermometer',   suffix: '%' },
                                    { id: 'modbus.0.inputRegisters.78_Pufferspeicher_Druck',    icon: 'wi wi-barometer',     suffix: 'bar'}
                                    
                                ]
                },
                { name: 'Druckluft',
                  deviceStates: [
                                    { id: 'modbus.0.inputRegisters.42_Druckluft_Dachboden1',       icon: 'wi wi-barometer',   suffix: 'bar' }
                                ]
                }
              ]
          }
        },
    

    do you see any failure in the code?

    Everything i see on the mirror is e.g. “— %”.

    Br Chris


  • Project Sponsor

    @Chris87-ux I’m a bit late to the party but as I’m tinkering with that module. too, maybe I can help.

    First, change the port to 8082. This seems to have been changed in one of the 2.x releases of the simple API.

    Second, go in ioBroker to the adapter setting for the web adater (!) and check “Eingebaute ‘Simple API’”
    Now the values should be pulled from ioBroker. Hope that helps.

    0_1576517940097_Bildschirmfoto 2019-12-16 um 18.36.38.png



  • @Fozi does not work 😞


  • Project Sponsor

    @falke69 is “[IPv4] 0.0.0.0 - Alle IP-Adressen zulassen” enabled?
    If this doesn’t work, too, the I’d ask bluefox in the ioBroker forum. There is also a very lenghty thread about that issue.



  • @Fozi have all settings exactly as in the screenshot


  • Project Sponsor

    @falke69 Damned…Then try port 8087, maybe this is your standard port.

    Are you using Homematic components, too? If so, then check MMM-Homematic. I switched to that module as its presentation is much nicer and the readouts of the actuators and sensors are translated and can be coloured if thresholds are met.



  • @Fozi have already installed MMM-Homematic.
    But found the other module better (line break)
    If all of my windows are open, everything is shown on one line


  • Project Sponsor

    @falke69 What I didn’t like with MMM-ioBroker, was that the door and windows sensor didn’t display “auf”/“zu” but “true”/“false” or “1”/“0”. I couldn’t find a place in the code to modify or translate the status messages, so I dropped it.


Log in to reply