MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Raspberry 2 clean install showing as black screen



  • Hi all i am buggers here i have been trying to get this working for a week was going to be a gift for my wife for mothers days but no time now , i have done many many clean installs and each time no matter what i havedone it only start with a black screen and no data on the screen at all, i have made sure that the onfig file is the sample and still no data on the screen, i have tried to access it with the ipaddress from a remote pc using port 8080 and cant see anything, i am new to this any help would be great please


  • Module Developer

    @adamrwolarczuk said in Raspberry 2 clean install showing as black screen:

    i have made sure that the onfig file is the sample

    You copied the sample, pasted it and renamed the copy to config.js?

    What is your terminal reporting?



  • i did yea and i am dumb ass when it comes to ths what do you need to know from the terminal



  • Starting MagicMirror: v2.3.1
    Loading config …
    Loading module helpers …
    No helper found for module: alert.
    Initializing new module helper …
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper …
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper …
    Module helper loaded: newsfeed
    All module helpers loaded.
    Starting server on port 8080 …
    Server started …
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started …
    Launching application.


  • Module Developer

    @adamrwolarczuk

    Well, it certainly shows that MM is launching and running. There are several black screen topics that you can look through. Do a forum search for black screen. Otherwise, perhaps someone else will chime in that had the same problem. I suspect that electron may be at fault or that your dependencies failed to install properly



  • i just ran the auto one and it didnt error at all i did a search and tried a few things and no dice



  • there is a bug in the electron browser that causes the black screen.

    i did

    npm remove electron
    npm install electron@1.7.9

    and it works fine now…

    someone posted another solution to issue 1243



  • @sdetweil said in Raspberry 2 clean install showing as black screen:

    npm remove electron
    npm install electron@1.7.9

    I will have to try that. Thank you! My fix had been to install another web browser and use that. Electron’s built-in browser seemed to always show a black screen.