MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Magic mirror install on Ubuntu 16.04



  • Hi everybody,

    Since 2 day’s I try to install Magic mirror on an clean install Ubuntu 16.04. Also tried the 19.x.
    I keep running in the same problem.
    When doing the “npm install” i got stuck on “extract rxjs@^6.4.0…” It stops there and nothing happens.
    What ever I try to do, I’m alway’s stuck on the “npm install” part.
    Anyone knows what’s going on or is this a known issue?



  • @Preve Hi there!
    The Other day I installed MM on the latest Linux Mint and it worked without any issues. All I did before the npm installwas to run curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash - which was poested by @Mykle1 poested in this post. There were no errors during the installation. Give it a try and report back if that worked for you. 🙂



  • @MadScientist

    After the 4’th re-install of the Ubuntu I’ve decided to go with ded.nodesource setup 8.x. Installed that and waited again for some time for a failure. This time I got a good error message regarding some permissions. There was even a commandline suggestuion on how to fix this. Done the required fix and suddenly the install of MM went onwards.
    So yes … now it runs fine. I wanted to test the Globe module and place all our branches on it. That works. Now showing my boss to placed this at the reception desk as an eye-catcher 🙂
    Now I have some small problems regarding the correct display on MMM Globe module. I can’t get the default pins to go away and only leave the ones I have set in the config file.


  • Project Sponsor Module Developer



  • @Mykle1 pleasse don’t Sir me. That’s not needed 🙂

    And yes, I have seen that post. One of the reasons why I went for Ubuntu since I had a decent computer for testing.