MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

used the amazing complete setup but after 'npm start'.....



  • I’ve received error messages (see below). WHat should I do?

    sh: 1: electron: not found

    npm ERR! Linux 4.4.34-v7+
    npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” "start"
    npm ERR! node v6.9.2
    npm ERR! npm v3.10.9
    npm ERR! file sh
    npm ERR! code ELIFECYCLE
    npm ERR! errno ENOENT
    npm ERR! syscall spawn
    npm ERR! magicmirror@2.0.0 start: electron js/electron.js
    npm ERR! spawn ENOENT
    npm ERR!
    npm ERR! Failed at the magicmirror@2.0.0 start script ‘electron js/electron.js’.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! electron js/electron.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs magicmirror
    npm ERR! Or if that isn’t available, you can get their info via:
    npm ERR! npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.

    npm ERR! Please include the following file with any support request:
    npm ERR! /home/pi/MagicMirror/npm-debug.log



  • @alonshwartz1966 you either are tring to start the mirror from the root folder or you didn’t install node.js correctly I believe. I’m on my cell sorry I could give a better answer. I’ll check later tonight


  • Module Developer

    Run the install script again.



  • please check if you had a stabile connection to the internet while running the install process of the mirror. just try it again if you are sure. Thix fixed my problem in the beginning



  • I’ve got the same Problem.
    Fresh installation of Raspian on an Raspberry Pi3.

    Running the install Script again doesn’t help.


  • Module Developer

    @Ancient said in used the amazing complete setup but after ‘npm start’.....:

    I’ve got the same Problem.
    Fresh installation of Raspian on an Raspberry Pi3.

    Running the install Script again doesn’t help.

    Even if you remove the magicmirror folder before running it again?

    I had a similar issue (don’t know if it was exactly the same, since I didn’t save the log).
    It seems like the Electron.js is the issue, in my case it was missing for some reason, removing the magicmirror folder and running the install script again did the trick for me.



  • Yep,
    deleteing as well as renaming the MagicMirror Folder won’t do the trick for me.
    Maybe it’s related to this Issue https://github.com/MichMich/MagicMirror/issues/567

    Where should the electron.js be located, i believe it’s missing here too.


  • Module Developer

    @Ancient said in used the amazing complete setup but after ‘npm start’.....:

    Yep,
    deleteing as well as renaming the MagicMirror Folder won’t do the trick for me.
    Maybe it’s related to this Issue https://github.com/MichMich/MagicMirror/issues/567

    Where should the electron.js be located, i believe it’s missing here too.

    In the magicmirror folder, node_modules and then electron or electron-prebuilt

    maybe try to install it manually?

    npm install electron --save-dev


  • Module Developer

    also, are you all running the X GUI or are you trying to start it directly from the prompt it boots in to?



  • I try to start it directly from the prompt

    npm install electron --save-dev

    electron@1.4.12 postinstall /home/pi/MagicMirror/node_modules/electron
    node install.js

    magicmirror@2.0.0 /home/pi/MagicMirror
    ├── electron@1.4.12
    └── UNMET PEER DEPENDENCY grunt@1.0.1

    npm WARN grunt-yamllint@0.2.0 requires a peer of grunt@~0.4.0 but none was installed.