MMM-NetworkScanner help needed


  • Module Developer

    Hi, and please help. Thank you.

    I’ve got this module running but the only devices that will show as active are the Github from the sample config and the showUnknown devices which I have turned off. All others that I have added appear as offline. I’m using the MAC addresses that I got from my router (and confirmed them with what MMM-NetworkScanner shows when I have showUnknown enabled) They are correct and all in lower case. I read where that might be an issue. I did git pull and npm install in the MMM-NetworkScanner folder. Also, if I change the 2nd device entry (below) to macAddress and enter the MykleDesktop macAddress, then the macAddress that was showing in showUnknown no longer appears, and still the device shows as offline. In other words, all my devices show their mac addresses as online if I don’t list them in devices. If I list them in devices, they show as offline and the showUnknown mac addresses disappear

    {
    module: ‘MMM-NetworkScanner’,
    position: ‘top_left’,
    config: {
    devices: [
    { ipAddress: “github.com”, name: “Github”, icon: “globe”},
    { ipAddress: “192.168.1.4”, name: “MykleDesktop”, icon: “desktop”},
    { macAddress: “mac.address.all.lower.case”, name: “DoveMBP”, icon: “laptop”},
    { macAddress: “mac.address.all.lower.case”, name: “MyklesiPhone”, icon: “mobile”},
    { macAddress: “mac.address.all.lower.case”, name: “JayAndroid”, icon: “mobile”},
    { macAddress: “mac.address.all.lower.case”, name: “DonnaMBP”, icon: “laptop”},
    { macAddress: “mac.address.all.lower.case”, name: “DonnaiPhone”, icon: “mobile”},
    { macAddress: “mac.address.all.lower.case”, name: “NikkiiPhone”, icon: “mobile”},
    ],
    showUnknown: false,
    showOffline: true,
    showLastSeen: true,
    keepAlive: 180,
    updateInterval: 10,
    residents: “Mobile”, // I tried this with each name of the devices above and each icon name and the default of []
    occupiedCMD: {notification: ‘TEST’, payload: {action: ‘occupiedCMD’}},
    vacantCMD: {notification: ‘TEST’, payload: {action: ‘vacantCMD’}},
    }



  • @Mykle1 try to execute the following in shell:

    arp-scan -l -q
    

    Compare all the scanned MAC with your MAC device entries in MMM-NetworkScanner.


  • Module Developer

    @slametps said in MMM-NetworkScanner help needed:

    arp-scan -l -q

    pi@Pi3:~ $ arp-scan -l -q
    You need to be root, or arp-scan must be SUID root, to open a link-layer socket.
    link_open: Operation not permitted
    pi@Pi3:~ $

    please advise



  • @Mykle1 sorry, my bad. The correct one:

    sudo arp-scan -l -q
    

  • Module Developer

    @slametps said in MMM-NetworkScanner help needed:

    sudo arp-scan -l -q

    I just checked all reported mac addresses against my device entries. They are all correct. Not one of them shows as online


  • Module Developer

    I can verify mac addresses not working for me either… I installed it to play with and the only way I can show anything online is using ip addresses…


  • Module Developer

    @cowboysdude said in MMM-NetworkScanner help needed:

    I can verify mac addresses not working for me either… I installed it to play with and the only way I can show anything online is using ip addresses…

    A quick fix, so far:

    I went into my FIOS router and assigned a “static lease” on the IP addresses of the devices that would not show in NetworkScanner with their MAC addresses. Went back into my config.js and changed the macAddress to ipAddress for each device and put in the static IP addresses I just assigned in the router.

    It’s working now, all except for the machine I am working on now (my desktop). It doesn’t show as active, even with a static lease on the IP address. That’s sort of alright, as I really just wanted the cell phones to appear, which they do, but odd, nonetheless. :-/

    Now two things that remain:

    1. I want to move the entire cell that contains NetworkScanner on the screen to the left. Could someone tell me where to find that?

    2. The phrase “was last seen 5 minutes ago” in NetworkScanner. Where do I go to edit that?



  • The mac address scanner was working up until yesterday when a new version came out. If you look at your logs you can see it is doing MAC scanning. Mine keeps throwing an error saying the module ‘ping’ is missing.

    I don’t want to scan by IP address because I have some machines that I don’t have ping enabled.


  • Module Developer

    @cowboysdude

    After I assigned static IP addresses via my FIOS router the scanner started working, somewhat. Then I rearranged my mirror, somewhat.

    0_1486855552533_IMG_1731edit.jpg 0_1486855587628_IMG_1732edit.jpg



  • @Mykle1 yap, mine is no longer working after updating the module :’( I think there is something wrong with the new module for MAC comparison. Hope the author fix this soon.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.