Default Weather module not loading and no error showing.



  • Hi all,

    I’m new at this magic mirror thingie. Just installed it on a raspberry Pi 2 and got my screen. Everything loads well (Private calendar, Compliments and personalized new feed.) What doesn’t work is the Weather module. It’s not showing at all. So I don’t get any kind of error.
    I’ve entered my API key and location found in the openweatherpmap website. But space where the module should be on my screen is empty. No error, not a word.
    Anyone that can help me? Maybe I forgot to enable something?

    Kind regards


  • Moderator

    @Preve
    Please post your config, but replace your personal keys/calendar links with XXX



  • /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     */
    
    var config = {
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"],
    
    	language: 'en',
    	timeFormat: 24,
    	units: 'metric',
    
    	modules: [
    		{
    			module: 'alert',
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: 'clock',
    			position: 'top_left'
    		},
    		{
    			module: 'calendar',
    			header: 'Personal Calendar',
    			position: 'top_left',
    			config: {
    				calendars: [
    					{
                                                    symbol: 'calendar-check-o ',
                                                    url: 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
                                            }
    				]
    			}
    		},
    		{
    			module: 'compliments',
    			position: 'lower_third'
    		},
    		{
    			module: 'currentweather',
    			position: 'top_right',
    			config: {
    				locationID: '2802154',
    				appid: 'XXXXXXXXXXXXXXXXXXXXXXX'
    			}
    		},
    		{
    			module: 'weatherforecast',
    			position: 'top_right',
    			header: 'Weather Forecast',
    			config: {
    				locationID: '2802154',
    				appid: 'XXXXXXXXXXXXXXXXXXXXXXX'
    			}
    		},
    		{
    			module: 'newsfeed',
    			position: 'bottom_bar',
    			config: {
    				feeds: [
    					{
    						title: "HLN BE",
    						url: "http://www.hln.be/rss.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== 'undefined') {module.exports = config;}
    

  • Moderator

    That in fact looks perfectly fine. Did you try to reboot your pi to check if currentweather comes up?
    Try to press F12 in the browser while MagicMirror is running and check the console for errors



  • Restarted MM a couple of times. I’ll reboot the PI and see what’s happening.



  • Nope, Rebooted the PI and still nothing.


  • Moderator

    And console of your browser does not show a single error?



  • How do I get there? Sorry for noobish question. It runs full screen.


  • Moderator

    If you press F12 in your browser you should see a development interface, one is called console and should show information, warnings and - maybe - errors


  • Moderator

    I just tried your currentweather settings with my appid and instantly see the current weather. Did you check your appid again?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.