Error Running Install Script



  • Hello,
    I am trying to run the basic install script from the front page of magicmirror.builders, on a Raspberry Pi 3 running the following OS version of Raspbian Jessie: Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

    From a clean install of Raspbian, I connected to my wifi network, ran apt-get update prior to running the script, and the following errors occur:

    > electron-chromedriver@1.6.0 install /home/pi/MagicMirror/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    
    > electron@1.6.10 postinstall /home/pi/MagicMirror/node_modules/electron
    > node install.js
    
    /home/pi/MagicMirror/node_modules/electron/install.js:47
      throw err
      ^
    
    Error: No checksum found in checksum file for "electron-v1.6.10-linux-arm.zip".
        at NoChecksumFoundError.Error (native)
        at NoChecksumFoundError.ErrorWithFilename (/home/pi/MagicMirror/node_modules/sumchecker/build.js:41:124)
        at new NoChecksumFoundError (/home/pi/MagicMirror/node_modules/sumchecker/build.js:88:131)
        at /home/pi/MagicMirror/node_modules/sumchecker/build.js:183:25
        at ChecksumValidator.validateFile (/home/pi/MagicMirror/node_modules/sumchecker/build.js:178:14)
        at /home/pi/MagicMirror/node_modules/sumchecker/build.js:215:21
        at Array.map (native)
        at ChecksumValidator.validateFiles (/home/pi/MagicMirror/node_modules/sumchecker/build.js:214:39)
        at /home/pi/MagicMirror/node_modules/sumchecker/build.js:170:23
    magicmirror@2.1.1 /home/pi/MagicMirror
    ├─┬ body-parser@1.17.2 
    │ ├── bytes@2.4.0 
    │ ├── content-type@1.0.2 
    │ ├─┬ debug@2.6.7 
    │ │ └── ms@2.0.0 
    │ ├── depd@1.1.0 
    │ ├─┬ http-errors@1.6.1 
    │ │ └── inherits@2.0.3 
    │ ├── iconv-lite@0.4.15 
    │ ├─┬ on-finished@2.3.0 
    │ │ └── ee-first@1.1.1 
    │ ├── qs@6.4.0 
    │ ├─┬ raw-body@2.2.0 
    │ │ ├── iconv-lite@0.4.15 
    │ │ └── unpipe@1.0.0 
    │ └─┬ type-is@1.6.15 
    │   └── media-typer@0.3.0 
    ├─┬ chai@3.5.0 
    │ ├── assertion-error@1.0.2 
    │ ├─┬ deep-eql@0.1.3 
    │ │ └── type-detect@0.1.1 
    │ └── type-detect@1.0.0 
    ├─┬ chai-as-promised@6.0.0 
    │ └── check-error@1.0.2 
    ├── colors@1.1.2 
    ├─┬ express@4.15.3 
    │ ├─┬ accepts@1.3.3 
    │ │ └── negotiator@0.6.1 
    │ ├── array-flatten@1.1.1 
    │ ├── content-disposition@0.5.2 
    │ ├── cookie@0.3.1 
    │ ├── cookie-signature@1.0.6 
    │ ├── encodeurl@1.0.1 
    │ ├── escape-html@1.0.3 
    │ ├── etag@1.8.0 
    │ ├── finalhandler@1.0.3 
    │ ├── fresh@0.5.0 
    │ ├── merge-descriptors@1.0.1 
    │ ├── methods@1.1.2 
    │ ├── parseurl@1.3.1 
    │ ├── path-to-regexp@0.1.7 
    │ ├─┬ proxy-addr@1.1.4 
    │ │ ├── forwarded@0.1.0 
    │ │ └── ipaddr.js@1.3.0 
    │ ├── range-parser@1.2.0 
    │ ├─┬ send@0.15.3 
    │ │ ├── destroy@1.0.4 
    │ │ └── mime@1.3.4 
    │ ├── serve-static@1.12.3 
    │ ├── setprototypeof@1.0.3 
    │ ├── statuses@1.3.1 
    │ ├── utils-merge@1.0.0 
    │ └── vary@1.1.1 
    ├─┬ express-ipfilter@0.2.4 
    │ ├── ip@1.1.5 
    │ ├── lodash@3.10.1 
    │ └─┬ range_check@1.4.0 
    │   ├── ip6@0.0.4 
    │   └── ipaddr.js@1.2.0 
    ├─┬ feedme@1.0.0 
    │ ├── clarinet@0.11.0 
    │ ├── eventyoshi@0.1.8 
    │ └── sax@1.2.2 
    ├─┬ grunt@1.0.1 
    │ ├── coffee-script@1.10.0 
    │ ├─┬ dateformat@1.0.12 
    │ │ ├── get-stdin@4.0.1 
    │ │ └─┬ meow@3.7.0 
    │ │   ├─┬ camelcase-keys@2.1.0 
    │ │   │ └── camelcase@2.1.1 
    │ │   ├── decamelize@1.2.0 
    │ │   ├─┬ loud-rejection@1.6.0 
    │ │   │ ├─┬ currently-unhandled@0.4.1 
    │ │   │ │ └── array-find-index@1.0.2 
    │ │   │ └── signal-exit@3.0.2 
    │ │   ├── map-obj@1.0.1 
    │ │   ├── minimist@1.2.0 
    │ │   ├─┬ normalize-package-data@2.3.8 
    │ │   │ ├── hosted-git-info@2.4.2 
    │ │   │ ├─┬ is-builtin-module@1.0.0 
    │ │   │ │ └── builtin-modules@1.1.1 
    │ │   │ └─┬ validate-npm-package-license@3.0.1 
    │ │   │   ├─┬ spdx-correct@1.0.2 
    │ │   │   │ └── spdx-license-ids@1.2.2 
    │ │   │   └── spdx-expression-parse@1.0.4 
    │ │   ├─┬ read-pkg-up@1.0.1 
    │ │   │ ├── find-up@1.1.2 
    │ │   │ └─┬ read-pkg@1.1.0 
    │ │   │   ├─┬ load-json-file@1.1.0 
    │ │   │   │ ├─┬ parse-json@2.2.0 
    │ │   │   │ │ └─┬ error-ex@1.3.1 
    │ │   │   │ │   └── is-arrayish@0.2.1 
    │ │   │   │ └─┬ strip-bom@2.0.0 
    │ │   │   │   └── is-utf8@0.2.1 
    │ │   │   └── path-type@1.1.0 
    │ │   ├─┬ redent@1.0.0 
    │ │   │ ├─┬ indent-string@2.1.0 
    │ │   │ │ └── repeating@2.0.1 
    │ │   │ └── strip-indent@1.0.1 
    │ │   └── trim-newlines@1.0.0 
    │ ├── eventemitter2@0.4.14 
    │ ├── exit@0.1.2 
    │ ├─┬ findup-sync@0.3.0 
    │ │ └── glob@5.0.15 
    │ ├─┬ glob@7.0.6 
    │ │ ├── fs.realpath@1.0.0 
    │ │ ├─┬ inflight@1.0.6 
    │ │ │ └── wrappy@1.0.2 
    │ │ └── once@1.4.0 
    │ ├─┬ grunt-cli@1.2.0 
    │ │ └── resolve@1.1.7 
    │ ├── grunt-known-options@1.1.0 
    │ ├─┬ grunt-legacy-log@1.0.0 
    │ │ ├─┬ grunt-legacy-log-utils@1.0.0 
    │ │ │ └── lodash@4.3.0 
    │ │ └── underscore.string@3.2.3 
    │ ├─┬ grunt-legacy-util@1.0.0 
    │ │ ├── async@1.5.2 
    │ │ ├── getobject@0.1.0 
    │ │ ├── lodash@4.3.0 
    │ │ └─┬ which@1.2.14 
    │ │   └── isexe@2.0.0 
    │ ├─┬ js-yaml@3.5.5 
    │ │ ├─┬ argparse@1.0.9 
    │ │ │ └── sprintf-js@1.0.3 
    │ │ └── esprima@2.7.3 
    │ ├─┬ minimatch@3.0.4 
    │ │ └─┬ brace-expansion@1.1.7 
    │ │   ├── balanced-match@0.4.2 
    │ │   └── concat-map@0.0.1 
    │ ├─┬ nopt@3.0.6 
    │ │ └── abbrev@1.1.0 
    │ ├── path-is-absolute@1.0.1 
    │ └── rimraf@2.2.8 
    ├─┬ grunt-eslint@19.0.0 
    │ ├─┬ chalk@1.1.3 
    │ │ ├── ansi-styles@2.2.1 
    │ │ ├─┬ has-ansi@2.0.0 
    │ │ │ └── ansi-regex@2.1.1 
    │ │ ├── strip-ansi@3.0.1 
    │ │ └── supports-color@2.0.0 
    │ └─┬ eslint@3.19.0 
    │   ├─┬ babel-code-frame@6.22.0 
    │   │ └── js-tokens@3.0.1 
    │   ├─┬ concat-stream@1.6.0 
    │   │ ├─┬ readable-stream@2.2.9 
    │   │ │ ├── buffer-shims@1.0.0 
    │   │ │ ├── isarray@1.0.0 
    │   │ │ ├── process-nextick-args@1.0.7 
    │   │ │ ├── string_decoder@1.0.1 
    │   │ │ └── util-deprecate@1.0.2 
    │   │ └── typedarray@0.0.6 
    │   ├─┬ doctrine@2.0.0 
    │   │ └── isarray@1.0.0 
    │   ├─┬ escope@3.6.0 
    │   │ ├─┬ es6-map@0.1.5 
    │   │ │ ├── d@1.0.0 
    │   │ │ ├── es5-ext@0.10.21 
    │   │ │ ├── es6-iterator@2.0.1 
    │   │ │ ├── es6-set@0.1.5 
    │   │ │ ├── es6-symbol@3.1.1 
    │   │ │ └── event-emitter@0.3.5 
    │   │ ├── es6-weak-map@2.0.2 
    │   │ └─┬ esrecurse@4.1.0 
    │   │   └── estraverse@4.1.1 
    │   ├─┬ espree@3.4.3 
    │   │ ├── acorn@5.0.3 
    │   │ └─┬ acorn-jsx@3.0.1 
    │   │   └── acorn@3.3.0 
    │   ├── esquery@1.0.0 
    │   ├── estraverse@4.2.0 
    │   ├── esutils@2.0.2 
    │   ├─┬ file-entry-cache@2.0.0 
    │   │ └─┬ flat-cache@1.2.2 
    │   │   ├── circular-json@0.3.1 
    │   │   ├─┬ del@2.2.2 
    │   │   │ ├─┬ globby@5.0.0 
    │   │   │ │ ├─┬ array-union@1.0.2 
    │   │   │ │ │ └── array-uniq@1.0.3 
    │   │   │ │ └── arrify@1.0.1 
    │   │   │ ├── is-path-cwd@1.0.0 
    │   │   │ ├─┬ is-path-in-cwd@1.0.0 
    │   │   │ │ └── is-path-inside@1.0.0 
    │   │   │ └── pify@2.3.0 
    │   │   ├── graceful-fs@4.1.11 
    │   │   └─┬ write@0.2.1 
    │   │     └─┬ mkdirp@0.5.1 
    │   │       └── minimist@0.0.8 
    │   ├── glob@7.1.2 
    │   ├── globals@9.17.0 
    │   ├── ignore@3.3.3 
    │   ├── imurmurhash@0.1.4 
    │   ├─┬ inquirer@0.12.0 
    │   │ ├── ansi-escapes@1.4.0 
    │   │ ├─┬ cli-cursor@1.0.2 
    │   │ │ └─┬ restore-cursor@1.0.1 
    │   │ │   ├── exit-hook@1.1.1 
    │   │ │   └── onetime@1.1.0 
    │   │ ├── cli-width@2.1.0 
    │   │ ├── lodash@4.17.4 
    │   │ ├─┬ readline2@1.0.1 
    │   │ │ ├── code-point-at@1.1.0 
    │   │ │ ├── is-fullwidth-code-point@1.0.0 
    │   │ │ └── mute-stream@0.0.5 
    │   │ ├── run-async@0.1.0 
    │   │ ├── rx-lite@3.1.2 
    │   │ └── string-width@1.0.2 
    │   ├─┬ is-my-json-valid@2.16.0 
    │   │ ├── generate-function@2.0.0 
    │   │ ├─┬ generate-object-property@1.2.0 
    │   │ │ └── is-property@1.0.2 
    │   │ ├── jsonpointer@4.0.1 
    │   │ └── xtend@4.0.1 
    │   ├─┬ is-resolvable@1.0.0 
    │   │ └── tryit@1.0.3 
    │   ├─┬ json-stable-stringify@1.0.1 
    │   │ └── jsonify@0.0.0 
    │   ├─┬ levn@0.3.0 
    │   │ ├── prelude-ls@1.1.2 
    │   │ └── type-check@0.3.2 
    │   ├── lodash@4.17.4 
    │   ├─┬ mkdirp@0.5.0 
    │   │ └── minimist@0.0.8 
    │   ├── natural-compare@1.4.0 
    │   ├─┬ optionator@0.8.2 
    │   │ ├── deep-is@0.1.3 
    │   │ ├── fast-levenshtein@2.0.6 
    │   │ └── wordwrap@1.0.0 
    │   ├── path-is-inside@1.0.2 
    │   ├── pluralize@1.2.1 
    │   ├── progress@1.1.8 
    │   ├─┬ require-uncached@1.0.3 
    │   │ ├─┬ caller-path@0.1.0 
    │   │ │ └── callsites@0.2.0 
    │   │ └── resolve-from@1.0.1 
    │   ├─┬ shelljs@0.7.7 
    │   │ ├── interpret@1.0.3 
    │   │ └── rechoir@0.6.2 
    │   ├── strip-bom@3.0.0 
    │   ├─┬ table@3.8.3 
    │   │ ├── ajv-keywords@1.5.1 
    │   │ ├── lodash@4.17.4 
    │   │ ├── slice-ansi@0.0.4 
    │   │ └─┬ string-width@2.0.0 
    │   │   └── is-fullwidth-code-point@2.0.0 
    │   └─┬ user-home@2.0.0 
    │     └── os-homedir@1.0.2 
    ├─┬ grunt-jsonlint@1.1.0 
    │ ├─┬ jsonlint@1.6.2 
    │ │ ├── JSV@4.0.2 
    │ │ └─┬ nomnom@1.8.1 
    │ │   ├─┬ chalk@0.4.0 
    │ │   │ ├── ansi-styles@1.0.0 
    │ │   │ ├── has-color@0.1.7 
    │ │   │ └── strip-ansi@0.1.1 
    │ │   └── underscore@1.6.0 
    │ └── strip-json-comments@2.0.1 
    ├─┬ grunt-markdownlint@1.0.38 
    │ └─┬ markdownlint@0.5.0 
    │   └─┬ markdown-it@8.3.1 
    │     ├── entities@1.1.1 
    │     ├── linkify-it@2.0.3 
    │     ├── mdurl@1.0.1 
    │     └── uc.micro@1.0.3 
    ├── grunt-stylelint@0.8.0 
    ├─┬ grunt-yamllint@0.3.0 
    │ ├─┬ async@2.4.1 
    │ │ └── lodash@4.17.4 
    │ └─┬ js-yaml@3.8.4 
    │   └── esprima@3.1.3 
    ├─┬ helmet@3.6.1 
    │ ├── connect@3.6.2 
    │ ├── dns-prefetch-control@0.1.0 
    │ ├── dont-sniff-mimetype@1.0.0 
    │ ├── expect-ct@0.1.0 
    │ ├── frameguard@3.0.0 
    │ ├─┬ helmet-csp@2.4.0 
    │ │ ├── camelize@1.0.0 
    │ │ ├─┬ content-security-policy-builder@1.1.0 
    │ │ │ └── dashify@0.2.2 
    │ │ ├── dasherize@2.0.0 
    │ │ ├── lodash.reduce@4.6.0 
    │ │ └── platform@1.3.3 
    │ ├── hide-powered-by@1.0.0 
    │ ├── hpkp@2.0.0 
    │ ├─┬ hsts@2.0.0 
    │ │ └── core-util-is@1.0.2 
    │ ├── ienoopen@1.0.0 
    │ ├── nocache@2.0.0 
    │ ├── referrer-policy@1.1.0 
    │ └── x-xss-protection@1.0.0 
    ├─┬ http-auth@3.1.3 
    │ ├─┬ apache-crypt@1.2.1 
    │ │ └── unix-crypt-td-js@1.0.0 
    │ ├── apache-md5@1.1.2 
    │ ├── bcryptjs@2.4.3 
    │ └── uuid@3.0.1 
    ├── iconv-lite@0.4.17 
    ├─┬ mocha@3.4.2 
    │ ├── browser-stdout@1.3.0 
    │ ├─┬ commander@2.9.0 
    │ │ └── graceful-readlink@1.0.1 
    │ ├─┬ debug@2.6.0 
    │ │ └── ms@0.7.2 
    │ ├── diff@3.2.0 
    │ ├── escape-string-regexp@1.0.5 
    │ ├── glob@7.1.1 
    │ ├── growl@1.9.2 
    │ ├── json3@3.3.2 
    │ ├─┬ lodash.create@3.1.1 
    │ │ ├─┬ lodash._baseassign@3.2.0 
    │ │ │ ├── lodash._basecopy@3.0.1 
    │ │ │ └─┬ lodash.keys@3.1.2 
    │ │ │   ├── lodash._getnative@3.9.1 
    │ │ │   ├── lodash.isarguments@3.1.0 
    │ │ │   └── lodash.isarray@3.0.4 
    │ │ ├── lodash._basecreate@3.0.3 
    │ │ └── lodash._isiterateecall@3.0.9 
    │ ├─┬ mkdirp@0.5.1 
    │ │ └── minimist@0.0.8 
    │ └─┬ supports-color@3.1.2 
    │   └── has-flag@1.0.0 
    ├── moment@2.18.1 
    ├─┬ request@2.81.0 
    │ ├── aws-sign2@0.6.0 
    │ ├── aws4@1.6.0 
    │ ├── caseless@0.12.0 
    │ ├─┬ combined-stream@1.0.5 
    │ │ └── delayed-stream@1.0.0 
    │ ├── extend@3.0.1 
    │ ├── forever-agent@0.6.1 
    │ ├─┬ form-data@2.1.4 
    │ │ └── asynckit@0.4.0 
    │ ├─┬ har-validator@4.2.1 
    │ │ ├─┬ ajv@4.11.8 
    │ │ │ └── co@4.6.0 
    │ │ └── har-schema@1.0.5 
    │ ├─┬ hawk@3.1.3 
    │ │ ├── boom@2.10.1 
    │ │ ├── cryptiles@2.0.5 
    │ │ ├── hoek@2.16.3 
    │ │ └── sntp@1.0.9 
    │ ├─┬ http-signature@1.1.1 
    │ │ ├── assert-plus@0.2.0 
    │ │ ├─┬ jsprim@1.4.0 
    │ │ │ ├── assert-plus@1.0.0 
    │ │ │ ├── extsprintf@1.0.2 
    │ │ │ ├── json-schema@0.2.3 
    │ │ │ └── verror@1.3.6 
    │ │ └─┬ sshpk@1.13.0 
    │ │   ├── asn1@0.2.3 
    │ │   ├── assert-plus@1.0.0 
    │ │   ├── bcrypt-pbkdf@1.0.1 
    │ │   ├─┬ dashdash@1.14.1 
    │ │   │ └── assert-plus@1.0.0 
    │ │   ├── ecc-jsbn@0.1.1 
    │ │   ├─┬ getpass@0.1.7 
    │ │   │ └── assert-plus@1.0.0 
    │ │   ├── jodid25519@1.0.2 
    │ │   ├── jsbn@0.1.1 
    │ │   └── tweetnacl@0.14.5 
    │ ├── is-typedarray@1.0.0 
    │ ├── isstream@0.1.2 
    │ ├── json-stringify-safe@5.0.1 
    │ ├─┬ mime-types@2.1.15 
    │ │ └── mime-db@1.27.0 
    │ ├── oauth-sign@0.8.2 
    │ ├── performance-now@0.2.0 
    │ ├── safe-buffer@5.0.1 
    │ ├── stringstream@0.0.5 
    │ ├─┬ tough-cookie@2.3.2 
    │ │ └── punycode@1.4.1 
    │ └── tunnel-agent@0.6.0 
    ├── rrule-alt@2.2.5 
    ├── simple-git@1.73.0 
    ├─┬ socket.io@1.7.4 
    │ ├─┬ debug@2.3.3 
    │ │ └── ms@0.7.2 
    │ ├─┬ engine.io@1.8.4 
    │ │ ├── base64id@1.0.0 
    │ │ ├─┬ debug@2.3.3 
    │ │ │ └── ms@0.7.2 
    │ │ ├─┬ engine.io-parser@1.3.2 
    │ │ │ ├── after@0.8.2 
    │ │ │ ├── arraybuffer.slice@0.0.6 
    │ │ │ ├── base64-arraybuffer@0.1.5 
    │ │ │ ├── blob@0.0.4 
    │ │ │ └── wtf-8@1.0.0 
    │ │ └─┬ ws@1.1.4 
    │ │   ├── options@0.0.6 
    │ │   └── ultron@1.0.2 
    │ ├─┬ has-binary@0.1.7 
    │ │ └── isarray@0.0.1 
    │ ├── object-assign@4.1.0 
    │ ├─┬ socket.io-adapter@0.5.0 
    │ │ └─┬ debug@2.3.3 
    │ │   └── ms@0.7.2 
    │ ├─┬ socket.io-client@1.7.4 
    │ │ ├── backo2@1.0.2 
    │ │ ├── component-bind@1.0.0 
    │ │ ├── component-emitter@1.2.1 
    │ │ ├─┬ debug@2.3.3 
    │ │ │ └── ms@0.7.2 
    │ │ ├─┬ engine.io-client@1.8.4 
    │ │ │ ├── component-emitter@1.2.1 
    │ │ │ ├── component-inherit@0.0.3 
    │ │ │ ├─┬ debug@2.3.3 
    │ │ │ │ └── ms@0.7.2 
    │ │ │ ├── has-cors@1.1.0 
    │ │ │ ├── parsejson@0.0.3 
    │ │ │ ├── parseqs@0.0.5 
    │ │ │ ├── ws@1.1.2 
    │ │ │ ├── xmlhttprequest-ssl@1.5.3 
    │ │ │ └── yeast@0.1.2 
    │ │ ├── indexof@0.0.1 
    │ │ ├── object-component@0.0.3 
    │ │ ├─┬ parseuri@0.0.5 
    │ │ │ └─┬ better-assert@1.0.2 
    │ │ │   └── callsite@1.0.0 
    │ │ └── to-array@0.1.4 
    │ └─┬ socket.io-parser@2.3.1 
    │   ├── component-emitter@1.1.2 
    │   └─┬ debug@2.2.0 
    │     └── ms@0.7.1 
    ├─┬ spectron@3.6.4 
    │ ├── dev-null@0.1.1 
    │ ├─┬ electron-chromedriver@1.6.0 
    │ │ ├─┬ electron-download@3.3.0 
    │ │ │ ├─┬ fs-extra@0.30.0 
    │ │ │ │ ├── jsonfile@2.4.0 
    │ │ │ │ ├── klaw@1.3.1 
    │ │ │ │ └── rimraf@2.6.1 
    │ │ │ ├── home-path@1.0.5 
    │ │ │ ├─┬ nugget@2.0.1 
    │ │ │ │ ├── pretty-bytes@1.0.4 
    │ │ │ │ ├─┬ progress-stream@1.2.0 
    │ │ │ │ │ ├── speedometer@0.1.4 
    │ │ │ │ │ └─┬ through2@0.2.3 
    │ │ │ │ │   ├─┬ readable-stream@1.1.14 
    │ │ │ │ │   │ └── string_decoder@0.10.31 
    │ │ │ │ │   └─┬ xtend@2.1.2 
    │ │ │ │ │     └── object-keys@0.4.0 
    │ │ │ │ ├── single-line-log@1.1.2 
    │ │ │ │ └── throttleit@0.0.2 
    │ │ │ ├─┬ path-exists@2.1.0 
    │ │ │ │ └─┬ pinkie-promise@2.0.1 
    │ │ │ │   └── pinkie@2.0.4 
    │ │ │ ├─┬ rc@1.2.1 
    │ │ │ │ ├── deep-extend@0.4.2 
    │ │ │ │ └── ini@1.3.4 
    │ │ │ ├── semver@5.3.0 
    │ │ │ └─┬ sumchecker@1.3.1 
    │ │ │   └── es6-promise@4.1.0 
    │ │ └─┬ extract-zip@1.6.5 
    │ │   ├─┬ debug@2.2.0 
    │ │   │ └── ms@0.7.1 
    │ │   └─┬ yauzl@2.4.1 
    │ │     └─┬ fd-slicer@1.0.1 
    │ │       └── pend@1.2.0 
    │ ├─┬ split@1.0.0 
    │ │ └── through@2.3.8 
    │ └─┬ webdriverio@4.8.0 
    │   ├─┬ archiver@1.3.0 
    │   │ ├─┬ archiver-utils@1.3.0 
    │   │ │ ├─┬ lazystream@1.0.0 
    │   │ │ │ └─┬ readable-stream@2.2.9 
    │   │ │ │   ├── isarray@1.0.0 
    │   │ │ │   └── string_decoder@1.0.1 
    │   │ │ ├── lodash@4.17.4 
    │   │ │ ├─┬ normalize-path@2.1.1 
    │   │ │ │ └── remove-trailing-separator@1.0.1 
    │   │ │ └─┬ readable-stream@2.2.9 
    │   │ │   ├── isarray@1.0.0 
    │   │ │   └── string_decoder@1.0.1 
    │   │ ├── async@2.4.1 
    │   │ ├── buffer-crc32@0.2.13 
    │   │ ├── lodash@4.17.4 
    │   │ ├─┬ readable-stream@2.2.9 
    │   │ │ ├── isarray@1.0.0 
    │   │ │ └── string_decoder@1.0.1 
    │   │ ├─┬ tar-stream@1.5.4 
    │   │ │ ├─┬ bl@1.2.1 
    │   │ │ │ └─┬ readable-stream@2.2.9 
    │   │ │ │   ├── isarray@1.0.0 
    │   │ │ │   └── string_decoder@1.0.1 
    │   │ │ ├── end-of-stream@1.4.0 
    │   │ │ ├─┬ readable-stream@2.2.9 
    │   │ │ │ ├── isarray@1.0.0 
    │   │ │ │ └── string_decoder@1.0.1 
    │   │ │ └── xtend@4.0.1 
    │   │ ├── walkdir@0.0.11 
    │   │ └─┬ zip-stream@1.1.1 
    │   │   ├─┬ compress-commons@1.2.0 
    │   │   │ ├─┬ crc32-stream@2.0.0 
    │   │   │ │ ├── crc@3.4.4 
    │   │   │ │ └─┬ readable-stream@2.2.9 
    │   │   │ │   ├── isarray@1.0.0 
    │   │   │ │   └── string_decoder@1.0.1 
    │   │   │ └─┬ readable-stream@2.2.9 
    │   │   │   ├── isarray@1.0.0 
    │   │   │   └── string_decoder@1.0.1 
    │   │   ├── lodash@4.17.4 
    │   │   └─┬ readable-stream@2.2.9 
    │   │     ├── isarray@1.0.0 
    │   │     └── string_decoder@1.0.1 
    │   ├─┬ babel-runtime@6.23.0 
    │   │ ├── core-js@2.4.1 
    │   │ └── regenerator-runtime@0.10.5 
    │   ├─┬ css-parse@2.0.0 
    │   │ └─┬ css@2.2.1 
    │   │   ├─┬ source-map@0.1.43 
    │   │   │ └── amdefine@1.0.1 
    │   │   ├─┬ source-map-resolve@0.3.1 
    │   │   │ ├── atob@1.1.3 
    │   │   │ ├── resolve-url@0.2.1 
    │   │   │ └── source-map-url@0.3.0 
    │   │   └── urix@0.1.0 
    │   ├── css-value@0.0.1 
    │   ├── deepmerge@1.3.2 
    │   ├── ejs@2.5.6 
    │   ├─┬ gaze@1.1.2 
    │   │ └─┬ globule@1.1.0 
    │   │   └── lodash@4.16.6 
    │   ├─┬ inquirer@3.0.6 
    │   │ ├─┬ cli-cursor@2.1.0 
    │   │ │ └─┬ restore-cursor@2.0.0 
    │   │ │   └─┬ onetime@2.0.1 
    │   │ │     └── mimic-fn@1.1.0 
    │   │ ├─┬ external-editor@2.0.4 
    │   │ │ ├── jschardet@1.4.2 
    │   │ │ └─┬ tmp@0.0.31 
    │   │ │   └── os-tmpdir@1.0.2 
    │   │ ├── figures@2.0.0 
    │   │ ├── lodash@4.17.4 
    │   │ ├── mute-stream@0.0.7 
    │   │ ├─┬ run-async@2.3.0 
    │   │ │ └── is-promise@2.1.0 
    │   │ ├── rx@4.1.0 
    │   │ └─┬ string-width@2.0.0 
    │   │   └── is-fullwidth-code-point@2.0.0 
    │   ├─┬ mkdirp@0.5.1 
    │   │ └── minimist@0.0.8 
    │   ├── npm-install-package@2.1.0 
    │   ├─┬ optimist@0.6.1 
    │   │ ├── minimist@0.0.10 
    │   │ └── wordwrap@0.0.3 
    │   ├── q@1.5.0 
    │   ├── rgb2hex@0.1.0 
    │   ├── supports-color@3.2.3 
    │   ├─┬ url@0.11.0 
    │   │ ├── punycode@1.3.2 
    │   │ └── querystring@0.2.0 
    │   ├── validator@7.0.0 
    │   ├── wdio-dot-reporter@0.0.8 
    │   └── wgxpath@1.0.0 
    ├── UNMET PEER DEPENDENCY stylelint@^7.8.0
    ├── stylelint-config-standard@16.0.0 
    ├─┬ time-grunt@1.4.0 
    │ ├─┬ date-time@1.1.0 
    │ │ └── time-zone@0.1.0 
    │ ├─┬ figures@1.7.0 
    │ │ └── object-assign@4.1.1 
    │ ├── hooker@0.2.3 
    │ ├── number-is-nan@1.0.1 
    │ ├─┬ pretty-ms@2.1.0 
    │ │ ├── is-finite@1.0.2 
    │ │ ├── parse-ms@1.0.1 
    │ │ └── plur@1.0.0 
    │ └── text-table@0.2.0 
    ├── valid-url@1.0.9 
    └─┬ walk@2.3.9 
      └── foreachasync@3.0.0 
    
    npm WARN grunt-stylelint@0.8.0 requires a peer of stylelint@^7.8.0 but none was installed.
    npm WARN stylelint-config-standard@16.0.0 requires a peer of stylelint@^7.8.0 but none was installed.
    npm ERR! Linux 4.4.50-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! node v6.10.3
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    
    npm ERR! electron@1.6.10 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@1.6.10 postinstall script 'node install.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the electron package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node install.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs electron
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls electron
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    Unable to install dependencies!
    
    

    After failing the first time, I formatted the micro SD card, started from scratch, but the same thing happened again. Any help would be greatly appreciated. Thank you!

    -Russ



  • @russifer

    I don’t know that it matters, but I’ve done all my MM installations while directly connected through ethernet, (not wif-fi). Also, in lieu of the automatic install script, I’ve done manual installations that were error free.

    If you don’t find a solution here, you could try deleting electron and reinstalling just that, as it appears the errors are electron based. If you are forced to start again from the beginning, I recommend following the tutorial precisely.

    Good luck.



  • I have the same problem. Can any help?



  • I installed electron@1.6.9 and it works.



  • @uzumon said in Error Running Install Script:

    I installed electron@1.6.9 and it works.

    There you go



  • How can I download the v.1.6.9?



  • @uzumon Thank you - that solved it for me.



  • @Lausbuab1 sudo npm install electron@1.6.9 -g



  • Found the solution for the problem:

    Automatic installation script run through if I make the following:

    This should be fixed now, I’ve added these missing entries to the file at https://github.com/electron/electron/releases/download/v1.6.10/SHASUMS256.txt

    You will need to delete the cached ~/.electron/SHASUMS256.txt-1.6.10 before re-installing, please confirm if it now works for you.

    (Author for Electron has written on his github)



  • @Lausbuab1 Tried downloading 1.6.9 and got this

    pi@raspberrypi:~ $ sudo npm install electron@1.6.9 -g
    /usr/bin/electron -> /usr/lib/node_modules/electron/cli.js
    
    > electron@1.6.9 postinstall /usr/lib/node_modules/electron
    > node install.js
    
    /usr/lib/node_modules/electron/install.js:47
      throw err
      ^
    
    Error: read ECONNRESET
        at exports._errnoException (util.js:1018:11)
        at TLSWrap.onread (net.js:568:26)
    npm ERR! Linux 4.9.24-v7+
    npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install" "electron@1.6.9" "-g"
    npm ERR! node v6.11.0
    npm ERR! npm  v3.10.10
    npm ERR! code ELIFECYCLE
    
    npm ERR! electron@1.6.9 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@1.6.9 postinstall script 'node install.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the electron package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node install.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs electron
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls electron
    npm ERR! There is likely additional logging output above.
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /home/pi/npm-debug.log
    
    

Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.