MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

MMM-Lunartic



  • @cowboysdude He helped me resolve the issue so its looking goooooooood!



  • Unfortunately no image is shown
    And i am not able to reach the linked homepage here (location germany)
    Is there a workaround?
    Thanks a lot


  • Project Sponsor Module Developer

    @Vauxdvihl said in MMM-Lunartic:

    Unfortunately no image is shown
    And i am not able to reach the linked homepage here (location germany)
    Is there a workaround?

    Yes, the API is down. However, there is a workaround. (temporary fix)

    1. Do a “git pull” in the MMM-Lunartic directory to make sure the module is up to date
    2. Rename your current MMM-Lunartic.js file to MMM-Lunartic.bak
    3. You will now notice a folder named “temporary fix” inside the module folder. Inside the “temporary fix” folder is another MMM-Lunartic.js file. Copy and paste that to the root of the MMM-Lunartic folder.
    4. Restart MM


  • @Mykle1
    👍
    Thanks a lot
    it works


  • Project Sponsor Module Developer

    @Vauxdvihl said in MMM-Lunartic:

    Thanks a lot

    You’re welcome. 👍

    it works

    A minor miracle. 🙂



  • @Mykle1 said in MMM-Lunartic:

    @Vauxdvihl said in MMM-Lunartic:

    Unfortunately no image is shown
    And i am not able to reach the linked homepage here (location germany)
    Is there a workaround?

    Yes, the API is down. However, there is a workaround. (temporary fix)

    1. Do a “git pull” in the MMM-Lunartic directory to make sure the module is up to date
    2. Rename your current MMM-Lunartic.js file to MMM-Lunartic.bak
    3. You will now notice a folder named “temporary fix” inside the module folder. Inside the “temporary fix” folder is another MMM-Lunartic.js file. Copy and paste that to the root of the MMM-Lunartic folder.
    4. Restart MM

    Hi @Mykle1,
    I tried to do your work around but I only see this writing: “When the Moon hits your eye…”

    This is my configuration:

    {
    			disabled: false,
    			module: 'MMM-Lunartic',
    			//position: 'bottom_center', // Best in left, center, or right regions
    			pages: {Prova: "top_left"},
    			config: {
    				mode: "rotating", // rotating or static
    				image: "current", // animation, current, DayNight or static
    				distance: "miles", // miles or km
    				sounds: "yes", // howling wolf, only on a full moon
    				useHeader: false, // true if you want a header
    				header: "The Lunartic is in my head", // Any text you want
    				maxWidth: "300px",
    				animationSpeed: 0,
    				rotateInterval: 15000,
    					}
    		},
    

    Could you help me?

    Many thanks!


  • Project Sponsor Module Developer

    @Egnos

    I’m surprised you even saw “When the Moon hits your eye…” at all.

    I don’t know where this came from --> pages: {Prova: “top_left”},

    This works:

    {
    			disabled: false,
    			module: 'MMM-Lunartic',
    			position: 'bottom_center', // Best in left, center, or right regions
    		//	pages: {Prova: "top_left"},
    			config: {
    				mode: "rotating", // rotating or static
    				image: "current", // animation, current, DayNight or static
    				distance: "miles", // miles or km
    				sounds: "yes", // howling wolf, only on a full moon
    				useHeader: false, // true if you want a header
    				header: "The Lunartic is in my head", // Any text you want
    				maxWidth: "300px",
    				animationSpeed: 0,
    				rotateInterval: 15000,
    					}
    		},
    


  • @Mykle1 said in MMM-Lunartic:

    hen the Moon hits your eye…” at

    Thanks @Mykle1.
    My MM has multiple pages and uses the “MMM-Page-Selector” module.
    Using the configuration below I should display your module on the “Prova” page, but showing only "When the Moon hits your eye…”

    pages: {Prova: "top_left"},
    

    All other modules (about 21 …) respect this rule …

    Could you do something?

    Thanks a lot!


  • Project Sponsor Module Developer

    @Egnos

    Well, first a question. Does it work with the default config entry after you’ve done the temporary fix?



  • @Mykle1 said in MMM-Lunartic:

    @Egnos

    Well, first a question. Does it work with the default config entry after you’ve done the temporary fix?

    Yes, if you comment the line

    //	pages: {Prova: "top_left"},
    

    the module seems to work correctly.

    I did this test using a new “config.js”, without the other 21 modules.
    It is also possible that Lunartic conflicts with some other module.
    Here are the modules I installed:

    MMM-iFrame-Ping
    MMM-Page-Selector
    MM-orrery
    MMM-DarkSkyForecast
    MMM-ISS
    MMM-RTSPStream
    planetrise
    MMM-EARTH-Live
    MMM-ISS-Live
    MMM-Screencast
    MMM-Formula1
    MMM-Lunartic
    MMM-SoccerLiveScore
    MMM-Globe
    MMM-MyCommute
    mmm-suncalc
    MMM-GoogleMapsTraffic
    MMM-page-indicator
    MMM-Voice-Commands

    Thanks.