Cannot access to MagicMirror despite IpWhiteList



  • Hi MagicMirror users,

    I have an issue.
    I can’t access to my brand new MagicMirror (other than localhost) despite having a proper IpWhiteList configuration.

    I’m building a small server on a tiny computer running Debian 9 (Stretch). The project is using it to control my home (Home Assistant), run MagicMirror in server mode, and maybe do some facial recognition later…

    I installed Home Assistant with no problem and can access to the web panel from another computer within my home network (so, fine… Everything is ok).

    Then, I installed and configured MagicMirror. It works without problem on my localhost.
    But unfortunately, I cannot access it elsewere using the IP of my server 192.168.X.X:8080.

    My IpWhiteList config is:

    var config = {
            port: 8080,
            ipWhitelist: [],
    

    The CLI gives this:

    XXX@serveur:~/MagicMirror$ npm start
    
    > magicmirror@2.1.3 start /home/XXX/MagicMirror
    > sh run-start.sh
    
    Gtk-Message: Failed to load module "canberra-gtk-module"
    Starting MagicMirror: v2.1.3
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper ...
    Module helper loaded: calendar
    Initializing new module helper ...
    Module helper loaded: newsfeed
    Initializing new module helper ...
    Module helper loaded: MMM-Paris-RATP-PG
    Initializing new module helper ...
    Module helper loaded: MMM-cryptocurrency
    Initializing new module helper ...
    Module helper loaded: MMM-WunderGround
    Initializing new module helper ...
    Module helper loaded: MMM-Remote-Control
    All module helpers loaded.
    Starting server on port 8080 ... 
    You're using a full whitelist configuration to allow for all IPs
    Server started ...
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Connecting socket for: MMM-Paris-RATP-PG
    Connecting socket for: MMM-cryptocurrency
    Cryptocurrency module loaded!
    Connecting socket for: MMM-WunderGround
    MMM-WunderGround helper started ...
    Connecting socket for: MMM-Remote-Control
    Starting node helper for: MMM-Remote-Control
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: https://calendar.google.com/calendar/XXX.ics - Interval: 300000
    Create new news fetcher for url: http://www.lemonde.fr/rss/une.xml - Interval: 300000
    GET_WUNDERGROUND
    

    And chrome gives me this:

    Ce site est inaccessible
    192.168.X.X n'autorise pas la connexion.
    Effectuez une recherche Google sur 192 168 8080.
    ERR_CONNECTION_REFUSED
    

    I don’t have any deny access on the CLI or another error message.
    Do you have a clue to help me out?

    Thank you all


  • Module Developer

    @MrNonoss said in Cannot access to MagicMirror despite IpWhiteList:

    var config = {
    port: 8080,
    ipWhitelist: [],

    Try this:

    var config = {
            port: 8080,
            address: "0.0.0.0",
            ipWhitelist: [],
    


  • Thank you for your tip @Mykle1, but unfortunately, it changed nothing.

    But looking at my CLI after launching MM, the end seems strange.
    Is it normal to stop like this?

    GET_WUNDERGROUND
    

  • Module Developer

    @MrNonoss said in Cannot access to MagicMirror despite IpWhiteList:

    Thank you for your tip @Mykle1, but unfortunately, it changed nothing.

    Ah, hmm. Are Home Assistant and MM accessing the same port?

    But looking at my CLI after launching MM, the end seems strange.
    Is it normal to stop like this?
    GET_WUNDERGROUND

    Yes, completely normal



  • Thank you for your quick reply.

    Nope, Home Assistant is using port 80



  • Hi all,

    I come back with a hint…
    There are two web server on my computer, but I didn’t installed any “Apache” or so, so I didn’t configured anything
    One is with Home Assistant (coded in Python) and the other one is the MagicMiror.

    Could it be a sort of conflict between these two?


  • Module Developer

    @MrNonoss

    If you remove or disable Home Assistant can you then connect to MagicMirror?



  • There’s no other option than deleting the installation folder.
    I tried, but, with no succes.

    I’m bored. Il will try to reinstall the whole things, starting by MM, testing --> If Ok --> Then Install Home Assistant and test again, it will give tips (I hope)

    Thank you again Mykle


  • Module Developer

    @MrNonoss

    You’re welcome, mate.

    I agree. Install MM first and get your connection established. Let me know how you make out.



  • Hi everyone,

    Problem solved with a new fresh install. Unfortunately, the issue came from me.
    From my config.js to be more accurate.

    My exact config.js was:

    var config = {
    	port: 8080,
    	adress: "0.0.0.0",
    	ipWhitelist: ["127.0.0.1", "192.168.1.1/24", "192.168.2.1/24", "192.168.2.100"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    

    My new and working one is the one Mykle1 gave me:

    var config = {
            port: 8080,
            address: "0.0.0.0",
            ipWhitelist: [],
    

    I assume it’s a coma mistake.
    Nothing to do with multi web server.

    Thank you again for your help.
    Best regards