MMM-Ruter (for Oslo and Akershus in Norway)


  • Module Developer

    @Kimzer I’m sorry, but I only make modules I need myself. If I move to Bergen, I let you know… 😉

    I did though do a quick search and it doesn’t seem that Skyss has any public API. Found a couple of unofficial/depricated onces, but that is not something I would support anyway…



  • Hi @Cato. Did something regarding the time change in the last update? Upgraded today and time format is set to 12 instead of 24 as it was before.

    This is what is in my config file (have not changed that recently)

    language: 'en',
    timeFormat: 24,
    units: 'metric',

  • Module Developer

    @amomat I have done nothing, and I can’t remember noticing that since I only use public transport in the morning. I will take a look tonight to make sure.



  • Hi @Cato. I’ve just installed your MMM-Ruter module, and I’m having issues with the time, it’s 12-hour…My Pi is 24 hour, my config is 24 hour…but the MMM-Ruter is 12 hour.

    language: "nb",
    timeFormat: 24,
    units: "metric",
    
    pi@MagicMirror_1:~/MagicMirror/config $ date
    Sun 13 Aug 15:26:42 CEST 2017
    

    Any idea how to fix this? 🙂


  • Module Developer

    Think I found the “bug” (oversight from my end). New version is now available.



  • @Cato said in MMM-Ruter (for Oslo and Akershus in Norway):

    Think I found the “bug” (oversight from my end). New version is now available.

    Just wanted to thank you for the lightning fast response!
    Now it shows 24h time. Cheers 🙂



  • Hei Cato!

    Great work with the this module. I have two problems:

    1. I cant get several stops on Frognerseterbanen (linje 1) to work (Vinderen (3012315), Gaustad (3012320) etc). It stops at ‘Loading’. Im trying in particular to get Vinderen T-bane. I have no other problems getting times from other stops, such as buses etc. Please see picture.
      0_1507061430183_IMG_3371.JPG

    2. How do I change the dimmed light on the time-text to be bright. Ive been through alle the files, but I cant find where you can change this. Im really quite new to this, but Ive managed to change text size and ‘dimmness’ on all other modules.

    Would be glad if you could help with these two! Thanks!



  • @kj3rra Did you manage to get those stops to work? I’m having the same problem. Some stops are working, but Vogts gate and Torshovparken recently (a couple of months ago) stopped working. Before that they were fine. I checked that the stop ID didn’t change.



  • So, I tried installing this module yesterday evening, upon finding that I got the same ‘Loading…’ message as described by @kj3rra and @jonaslaeret . Today I spend several hours trying to figure out the problem. I ended up running the mirror in server mode, and found to my surprise that on my PC the Ruter information was showing without a problem.
    This told me that the problem was either with Chromium or with Electron. Running

    sudo apt-get update chromium-browser
    

    didn’t seem to do the trick.

    I dug into the Electron documentation and found that adding the following to the config.js file makes the Ruter information show in Electron:

    electronOptions: { 
    		webPreferences: {
    			webSecurity: false
    		},
    	},
    

    Now, I get data from both Møllefaret and Røa T-bane 😃

    0_1536675829578_Møllefaret.JPG



  • I intalled this module the other day, but it isn’t removing trains that has left the station.

    After an hour my whole list is full of

    13 Oslo S -61 minutter
    13 Oslo S -31 minutter
    13 Oslo S -1 minutter
    13 Oslo S 16:21

    Has anyone got a solution to this issue?