new update/upgrade script, ready for testing


  • Project Sponsor Module Developer

    @sdetweil said in new update/upgrade script, ready for testing:

    Thanks for the test. Updated script to handle

    I wish I would have waited for the updated script. I went ahead and installed a new MM because I couldn’t move forward with what I am doing. Again, thanks for your scripts. I will continue to use them. They’re awesome. 👍



  • @Mykle1 I think u did the right thing. The “handle” is to bail out gracefully if there is no git repo locally (zip file install doesn’t provide any path forward, that I have found)


  • Project Sponsor Module Developer

    @sdetweil

    Understood, thanks. 🙂



  • Added some reporting of current version and version upgrading to.

    Also had path that did a live merge when u were just testing. Fixed that



  • another update… i was reporting ALL the files that changed between versions, but who cares (things are SUPPOSED the change!)… we only care if there is a conflict… fixed that



  • I am getting the below errors when trying to run your installer script, thoughts?

    bash: line 18: $’\r’: command not found
    bash: line 20: $’\r’: command not found
    bash: line 27: $’\r’: command not found
    bash: -c: line 28: syntax error near unexpected token $'{\r'' 'ash: -c: line 28:trim() {



  • @potts-mike thanks… try now… danged editing from windows got the wrong line end characters…



  • it ran with the following errors and magic mirror did not start.

    install log being saved to /home/pi/MagicMirror/installers/install.log
    Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
    Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
    Fetched 25.4 kB in 1s (22.4 kB/s)                              
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    build-essential is already the newest version (12.3).
    curl is already the newest version (7.52.1-5+deb9u9).
    git is already the newest version (1:2.11.0-3+deb9u4).
    unzip is already the newest version (6.0-21+deb9u2).
    wget is already the newest version (1.18-5+deb9u3).
    The following packages were automatically installed and are no longer required:
      coinor-libipopt1v5 libmumps-seq-4.10.0 libraw15
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    (node:4945) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    npm is already the newest version (1.4.21+ds-2).
    The following packages were automatically installed and are no longer required:
      coinor-libipopt1v5 libmumps-seq-4.10.0 libraw15
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    (node:4979) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
    npm WARN package.json path-is-inside@1.0.2 No README data
    npm WARN package.json sorted-object@2.0.1 No README data
    /usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
    /usr/local/bin/npx -> /usr/local/lib/node_modules/npm/bin/npx-cli.js
    npm WARN package.json config-chain@1.1.12 No license field.
    npm WARN package.json cyclist@0.2.2 No license field.
    npm WARN package.json json-schema@0.2.3 No license field.
    npm WARN package.json punycode@1.4.1 punycode is also the name of a node core module.
    npm WARN package.json qrcode-terminal@0.12.0 No license field.
    npm WARN package.json string_decoder@1.2.0 string_decoder is also the name of a node core module.
    npm@6.11.3 /usr/local/lib/node_modules/npm
    


  • @potts-mike can u send me the install.log, /home/pi/MagicMirror/installers/install.log

    same userid as here at gmail

    or post it here



  • @potts-mike also, try again… fixed a messaging problem

    but… you have MM already installed… (if the folder exists, cause the log is put there)…
    so, you should be using the update-script to bring to next version…