MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

remoteFile in compliments module



  • @roramirez Is there already a solution for the memory ‘bug’?


  • Core Contributors

    @jm What memory bug? I’ve don’t touch nothing there. @bhepler said about the improvement

    If you can help with this the Pull Requests are welcome 🙂



  • @roramirez I meant this comment:

    “As an aside, I’ve noticed that the weather integration technique continually adds to the arrays. So the memory usage will grow and grow at whatever frequency you set the compliment refresh. This isn’t terrible, as straight text doesn’t take a whole lot of memory. But it may have unintended effects”

    I don’t know whether to call this a bug, but you get my point 😉 I’m not an experienced coder whatsoever, so I doubt I might be of help, but I am always willing to test / assist.


  • Project Sponsor Module Developer

    @jm I can’t see that this is still happening on the current code base. Every time it tries to update an array will be generated with all possible values, after that the garbage collector will do his job and delete the array after usage.



  • Here is how I got the remote file compliments to work:

    1. The config.js settings must name the remote file with no path:
    		{
    			module: 'compliments',
    			position: 'bottom_bar',
    			config: {
    				remoteFile: 'compliments.json'
    			}
    		},        
    

    IMO it would be great if it were possible to put a full path the the remote file so it can be stored in the config directory.

    1. Create a compliments.json file and be sure to put double quotes around the array names like so:
    {
    	"morning" : [
    		"You're good enough, you're smart enough and doggone it, people like you!"
    	],
    	"afternoon" : [
    		"Yes those jeans make you look fat."
    	],
    	"evening" : [
    		"Please put on some pants."
    	]
    }
    
    
    1. Put the remote file (compliments.json) into the ~/MagicMirror/modules/default/compliments directory.

    2. Restart MM. It will show the default compliment (usually “Hi Sexy”) for the first interval and then will start showing compliments from the external file.

    Hope this helps



  • Guys where can be mistake:
    config.js looks like:

    {
    module: “compliments”,
    position: “lower_third”,
    config: {
    remoteFile: “compliments.json”
    }
    },

    Remote file placed in ~/MagicMirror/modules/default/compliments
    but it still does not work.
    I made all following above written steps and nothing - still oryginal compliments are one the mirror.
    I have no idea what is wrong.


  • Project Sponsor Module Developer

    @Lahim

    Your config entry looks okay. However, the curly quotes I see will cause problems. There should not be any in your config.js or your compliments.json file. This is an acceptable quote " but this is not. You can post your compliments.json file here (in a code block) so we can take a look at it.



  • I have in oryginal file so I just copied it. I also tried with but without luck.

    The compliments.json file looks like:

    {
        "anytime" : [
            "Dziala!"
        ],
        "morning" : [
            "Good morning, sunshine!",
            "Who needs coffee when you have your smile?",
            "Go get 'em, Tiger!"
        ],
        "afternoon" : [
            "dfadfafa",
            "dffffffff",
            "fsssss!"
        ],
        "evening" : [
            "2",
            "1",
            "3333"
        ]
    }
    

    In compliments.js

    Module.register("compliments", {
    
            // Module config defaults.
            defaults: {
                    compliments: {
                            anytime: [
                                    "Hey there sexy!"
                            ],
                            morning: [
                                    "Good morning, handsome!",
                                    "Enjoy your day!",
                                    "How was your sleep?"
                            ],
                            afternoon: [
                                    "Hello, beauty!",
                                    "You look sexy!",
                                    "Looking good today!"
                            ],
                            evening: [
                                    "Wow, you look hot!",
                                    "You look nice!",
                                    "Hi, sexy!"
                            ]
                    },
                    updateInterval: 30000,
                    remoteFile: null,
                    fadeSpeed: 4000
            },
    
    
    

    I see the “anytime” are without "
    so I also tried this in …json file but does not work.


  • Project Sponsor Module Developer

    @Lahim said in remoteFile in compliments module:

    so I also tried this in …json file but does not work.

    So, I copied your example compliments.json file from above and tested it. Here is my config.js entry:

    {
        disabled: false,
        module: "compliments",
        position: "lower_third",
        config: {
            updateInterval: 30000,
            fadeSpeed: 1000,
            remoteFile: "compliments.json", // this file is in the compliments module folder
    }
    },
    

    And this was the result:

    0_1513974362242_1.PNG 0_1513974370367_a.PNG 0_1513974379120_b.PNG

    So, as long as you haven’t changed anything else and your config entry is correct, and your compliments.json file is name correctly and in the compliments module folder, it should work, as it does here



  • Thank you for trying and helping but I copied your setup but still the same thing.

    Does compliments.json file has to be somehow written as json file? Or I can create new text file in nano and save it as compliments.json file? Does it need any special rights?
    Can you attach your .json file here so I can download and place it in the /compliments/ folder?

    Here is list of my files in compliments folder
    0_1513976348645_prt.jpg


Log in to reply