Problem with Weather Underground Forecast



  • Hi Folks, my first Post. Mirror is still in work and i hav a Problem with the module MMM-WunderGround. Each Time I put it in my config.js the mirror will not start. I don´t know what I am doing wrong, I put the Code

    modules: [
    {
        module: 'MMM-WunderGround',
        position: 'top_right',
        config: {
            apikey: 'xxxxxxxxxxxxx', // private; don't share! Put in my API 
            pws: 'pws:IGELDERL219', //culemborg Put in miy pws
            hourly: '1',
            fctext: '1',
            fcdaycount: "5",
            fcdaystart: "0",
            hourlyinterval: "3",
            hourlycount: "2",
            alerttime: 10000,
            alerttruncatestring: "english:",
    	roundTmpDecs: 1,
    	UseCardinals: 0,
    	layout: "horizontal",
    	sysstat: 0
        }
    };
    ]
    

    betweeen my Calendar and the Newsfeed, I try it also without modules:[ ], but it will not work, any Idea?


  • Moderator

    This is how it should look like … the modules : [] stuff should be there once only. And you closed the MMM-WunderGround module with a ; which tells javascript there is nothing to add afterwards, the command is complete. Therefore the rest is invalid syntax :)

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     */
    
    var config = {
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses.
    
    	language: "en",
    	timeFormat: 24,
    	units: "metric",
    
    	modules: [
    		{
    			module: "alert",
    		},
    		// OTHER MODULES .. blabla
    		{
    			module: 'MMM-WunderGround',
    			position: 'top_right',
    			config: {
    				apikey: 'xxxxxxxxxxxxx', // private; don't share! Put in my API 
    				pws: 'pws:IGELDERL219', //culemborg Put in miy pws
    				hourly: '1',
    				fctext: '1',
    				fcdaycount: "5",
    				fcdaystart: "0",
    				hourlyinterval: "3",
    				hourlycount: "2",
    				alerttime: 10000,
    				alerttruncatestring: "english:",
    			roundTmpDecs: 1,
    			UseCardinals: 0,
    			layout: "horizontal",
    			sysstat: 0
    			}
    		},
    		// ADDITIONAL MODULES ..
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "New York Times",
    						url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    


  • @yawns said in Problem with Weather Underground Forecast:

    {

    Thank you yawns, that fix the Mirror starts but the module did not show up, the first problem was because I am an absolute NOOB in Javascript,


  • Moderator

    @xeroxu
    No worries. So you don’t see anything of this module?



  • @yawns , Right I see nottthin, no Cuurent weather no forecast , nothing ,I dont know in the configuration options I´ve read about Locid, but i only find pws in my MMM-WunderGround.js. Is that the error


  • Module Developer

    @xeroxu said in Problem with Weather Underground Forecast:

    in the configuration options I´ve read about Locid, but i only find pws in my MMM-WunderGround.js. Is that the error

    I see the locid reference in the config options, too, but I don’t think that’s your problem. I just used your pws: 'pws:IGELDERL219', in my WunderGround and it loads and displays just fine.



  • @Mykle1 no chance it will no show up :…( where can I check my Weathe Underground API KEY, maybe is soething wrong with tthe API KEY, Whats the difference between API KEY and KEY ID? Sorry for my dumb questions,


  • Module Developer

    @xeroxu said in Problem with Weather Underground Forecast:

    where can I check my Weathe Underground API KEY, maybe is soething wrong with tthe API KEY,

    You can check your API key by going to https://www.wunderground.com/ and signing into your account. Once you’ve signed in, at the bottom of the page is Weather API. Click that! Your API KEY will be on the right side of the page, about 1/3 of the way down from the top. Copy and paste it into your config.js so it looks like this:
    apikey: '1234567891011',
    If you manually typed yours in you may have made a mistake and that’s all it takes to get no response from WonderGround.



  • @Mykle1 This also not works, I regenerate the Key and with the New One also nothing. Í think I stay on the default weather modules .



  • @Mykle1 There must be something wrong with the apikey. iI try it with the wuforecast module, and here also nothing show up.I have free Membership and choose the anvil plan. Have I to make big changes in the weatherunderground.js? I put in my API and Location pws.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.