Cant figure out how to install a module in the config.js



  • Hello im a student making the magic mirror project on my raspberry pi. I have installed the 3rd party modules in the modules directory but when when i try to add the module to the config.js and run the program it tells me theirs a error in my configuration file. do i add modules under the default modules or do i put then under the line that says “dont edit this text below”. i have tried adding the module both ways and it stil tells me somethings wrong with my config.js. i have also tried to install different modules and add them to the config.js with no luck. I think im doing something wrong but i cant figure out what. And i have followed the install instruction step by step.



  • @Edswald Post your config.js and with the installed module you got problem with so we can see that and see whats wrong. also all modules have to be under the default modules and not under the line that says “dont edit this text below”



  • @Edswald

    Here is an example of how to add a module to your config.js file. In this case, I am adding MMM-EARTH between the “clock” module and the “MMM-Cocktails” module. Notice how the clock module entry ends with },. The MMM-EARTH module begins with { and then ends with },. You will find the entry in the README for each module.

    modules: [
    		{
    			module: 'clock',
    			position: 'top_left'
    		},
    		{
        			module: "MMM-EARTH",
        			position: "bottom_center",
        			config: {
    			useHeader: false,
    			header: "NASA's EPIC Camera",
            		rotateInterval: 15000,
            		MaxWidth: "75%",
           			MaxHeight: "75%"
        		}
    		},
    		{
        			module: "MMM-Cocktails",
        			position: "bottom_left", // Small footprint - Fits anywhere.
        			config: {
            		maxWidth: "400px",
            		header: ""
        		}
    		},
    


  • in the config file you should have a modules: [ line. In fact, there should be almost at the end of the file an ]
    This mean modules is an array. ([ value1, value2, etc... ] is an array.
    Every value of the array is a dictionnary (a list of keys associates with a value) . it should look like this

    {
               key: value,
               next_key: value,
               etc..
    }
    

    Two key/value pair should be separated by a , and two dictionary should be separated by a ,
    as an example

    {
               key: value,
               next_key: value,
               etc..
    },
    {
               key: value,
               next_key: value,
               etc..
    }
    

    the , is very important because without it, it does’nt understand it changed value and you end up with an error because it doesn’t understand why you put a { or a : in the middle of an unfinished value

    What you should know is this : a [ is always closed by a ], if you having one without the other few characters later somethings is wrong. a { is always closed by a }, if you having one without the other few characters later somethings is wrong.
    two element in the same array should be separeted by ,. same thing with two element in a dictionnary.
    If you have a config issue it probably mean you forgot one of the following , { } [ ] : somewhere.
    Since you probably just copy past the config in the readme, my best bet is that you either forgot the first { or the last }, . Or maybe the configuration didn’t put a , at all at the end in their example because it suppose you add it at the end of the array. In that case
    The last element of the array might not have a , because it’s the last element. So if you add an alement after it, you have tu put it yourself.

    Hopefully that was clear enough



  • ok so here how my config file looks like i blacked out my twitter info but i think its right i dont know and thanks for everyone how is helping me with this your awesome!!!0_1493046075374_17bf40e2880333d8695ffe5511d2d047.png



  • @Edswald you didn’t put the module info at the right place and you missing

     ],
            paths: {
                    modules: "modules",
                    vendor: "vendor"
            }
    }
    

    just before the do not edit the line bellow.

    Your file should look like this at the end

                    {
                            module: "newsfeed",
                            position: "bottom_bar",
                            config: {
                                    feeds: [
                                            {
                                                    title: "New York Times",
                                                    url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
                                            }
                                    ],
                                    showSourceTitle: true,
                                    showPublishDate: true
                            }
                    },
    		{
    			module: 'twitControl',
    			position: 'top_left',
    			config: {
    				maxNumTweets: 5,
    				streamType: 'followings',
    				api_keys: {
    					consumer_key: 'YOUR CONSUMER KEY',
    					consumer_secret: 'YOUR CONSUMER SECRET',
    					access_token_key: 'YOUR ACCESS TOKEN KEY',
    					access_token_secret: 'YOUR ACCESS TOKEN SECRET'
    				}
    			}
    		},
            ],
            paths: {
                    modules: "modules",
                    vendor: "vendor"
            }
    }
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== 'undefined') {module.exports = config;}
    


  • ok so is this correct or am i suppose to put somthing in where it says modules and vendor. Its till not running 0_1493057568851_2017-04-24-120637_1280x1024_scrot.png


  • Module Developer

    @Edswald 0_1493058241706_1493057570459-2017-04-24-120637_1280x1024_scrot.jpg

    And for future reference, past the contents of the config in text format on the forum, it will be easier to see all of the config file then.



  • @broberg is this right me an my team mate are here trying to see if we missed anything. Its still not running.0_1493061502651_2017-04-24-131726_1280x1024_scrot.png


  • Module Developer

    @Edswald post it as text. can’t help you with only a screenshot


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.