MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

MMM-EARTH


  • Project Sponsor Module Developer

    Download:

    Update Version 1.0.2

    NASA changed their data AGAIN without consulting me AGAIN.

    The nerve!

    So, once again, a git pull in your MMM-EARTH directory should set things to right, AGAIN. :^)



  • Another old Noob trying to learn …
    I just started RPI and MM last week, changed some basic things in my config file.
    But EARTH will not turn (it is static).
    Can somebody have a look?

    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw http://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information how you can configurate this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	language: "nl",
    	timeFormat: 24,
    	units: "metric",
    
    	modules: [
    		{
        			module: "MMM-EARTH",
        			position: "top_center",
        			config: {
            		mode: "Natural",
            		rotateInterval: 15000,
            		MaxWidth: "20%",
            		MaxHeight: "20%",
        		}
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			header: "Feestdagen",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check-o ",
    						url: "https://www.mozilla.org/media/caldata/DutchHolidays.ics"
    					}
    				]
    			}
    		},
    		{
    			module: "",
    			position: "lower_third"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "Apeldoorn,Netherlands",
    				locationID: "",  //ID from http://www.openweathermap.org/help/city_list.txt
    				appid: "Xxxxxxxxxx"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weersvoorspelling",
    			config: {
    				location: "Apeldoorn,Netherlands",
    				locationID: "",  //ID from http://www.openweathermap.org/help/city_list.txt
    				appid: "Xxxxxxxx"
    			}
    		},
    		
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "Nu.nl",
    						url: "http://www.nu.nl/rss/Algemeen"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true
    			}
    		},
    	]
    
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    
    

    Thanks!
    Peter


  • Project Sponsor Module Developer

    @Peter

    Hello Peter. It is not your config that is causing the EARTH not to spin. I just loaded your config and it rotates the EARTH every 15 seconds as per rotateInterval: 15000,. Have you waited 15 seconds?
    Are you expecting it to rotate more quickly? Or is it not updating at all?

    One thing I did notice about your config:

    {
    			module: "",
    			position: "lower_third"
    		},
    

    An empty module name

    Also, you should remove your API keys before you post on the forum. You can remove yours from here by clicking the three dots at the bottom right of your post and choose EDIT.

    Lastly, I see you are using 20% MaxWidth and MaxHeight in MMM-EARTH, and that’s just fine, but you can also choose mode: "naturalThumb", at 100% to achieve the same thing with less system load on your Pi. But let’s get you fixed up first. 🙂



  • @Mykle1 thanks!
    It does not look like rotating.
    It goes black (fades to black) and comes back again.
    I will look at the other things you mention.
    Peter


  • Project Sponsor Module Developer

    @Peter

    Pay close attention. When it fades and comes back, is the picture different? It should be. Watch a few times to see please. If you do not want the fade in/ fade out then you can add this to your config entry for EARTH
    animationSpeed: 0,



  • @Mykle1 I removed the empty module name and the ID.
    Earth is turning, but I will take your advice to turn off the fading!
    I am learning every minute!
    Great!
    Peter


  • Project Sponsor Module Developer

    @Peter

    Yes, keep your API keys private. Use the config options to your liking. If you like the fade, keep it. It’s up to you.

    We’re all learning, Peter. At least, I hope so. I’m glad it’s working for you now. Peace! 🙂


  • Project Sponsor Module Developer

    I think this is amazing. MMM-EARTH has captured Hurricane Florence as moves across the Caribbean, taking aim at the Carolinas.

    0_1536624882671_Florence2.png


  • Project Sponsor Module Developer

    Announcement

    Anyone that experienced problems with MMM-EARTH yesterday can breathe a sigh of relief. It was not the module that was at fault. It was the API. Whatever problems they were having seem to be over. The module is now working as intended.


  • Module Developer

    @mykle1

    YAY!!! 😂 😂