MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Black screen after install update v2.2



  • Hello,
    after install the new update. I get a black screen at my MagicMirror.
    I get many warnings after npm install.

    //pi@Mirror:~/MagicMirror $ npm install
    
    > magicmirror@2.2.0 install /home/pi/MagicMirror
    > cd vendor && npm install
    
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    > magicmirror@2.2.0 postinstall /home/pi/MagicMirror
    > sh installers/postinstall/postinstall.sh && npm run install-fonts
    
    MagicMirror installation successful!
    
    > magicmirror@2.2.0 install-fonts /home/pi/MagicMirror
    > cd fonts && npm install
    
    magicmirror@2.2.0 /home/pi/MagicMirror
    ├─┬ mocha-logger@1.0.5
    │ └─┬ mocha@3.5.3
    │   ├─┬ commander@2.9.0
    │   │ └── graceful-readlink@1.0.1
    │   ├─┬ debug@2.6.8
    │   │ └── ms@2.0.0
    │   ├── diff@3.2.0
    │   ├── growl@1.9.2
    │   ├── json3@3.3.2
    │   ├─┬ lodash.create@3.1.1
    │   │ ├─┬ lodash._baseassign@3.2.0
    │   │ │ ├── lodash._basecopy@3.0.1
    │   │ │ └─┬ lodash.keys@3.1.2
    │   │ │   ├── lodash._getnative@3.9.1
    │   │ │   ├── lodash.isarguments@3.1.0
    │   │ │   └── lodash.isarray@3.0.4
    │   │ ├── lodash._basecreate@3.0.3
    │   │ └── lodash._isiterateecall@3.0.9
    │   ├─┬ mkdirp@0.5.1
    │   │ └── minimist@0.0.8
    │   └── supports-color@3.1.2
    └─┬ UNMET PEER DEPENDENCY stylelint@8.4.0
      ├── UNMET PEER DEPENDENCY postcss-less@1.1.3
      ├── UNMET PEER DEPENDENCY postcss-scss@1.0.2
      └── UNMET PEER DEPENDENCY sugarss@1.0.1
    
    npm WARN postcss-html@0.12.0 requires a peer of postcss-less@>=1.1.0 but none was installed.
    npm WARN postcss-html@0.12.0 requires a peer of postcss-scss@>=1.0.0 but none was installed.
    npm WARN postcss-html@0.12.0 requires a peer of sugarss@>=1.0.0 but none was installed.
    npm WARN stylelint-config-standard@16.0.0 requires a peer of stylelint@^7.8.0 but none was installed.
    
    


  • @Blackmirror can you run your mirror with npm start dev and check for errors in the console?



  • Okay. here:

    //Starting MagicMirror: v2.2.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: MMM-Carousel.
    WARNING! Could not load config file. Starting with default configuration. Error found: Error: Module version mismatch. Expected 50, got 53.
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: MMM-Carousel.
    App threw an error during load
    Error: Module version mismatch. Expected 50, got 53.
        at Error (native)
        at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
        at Object.Module._extensions..node (module.js:583:18)
        at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:173:20)
        at Module.load (module.js:473:32)
        at tryModuleLoad (module.js:432:12)
        at Function.Module._load (module.js:424:3)
        at Module.require (module.js:483:17)
        at require (internal/module.js:20:19)
        at bindings (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/bindings/bindings.js:76:44)
    Whoops! There was an uncaught exception...
    Error: Module version mismatch. Expected 50, got 53.
        at Error (native)
        at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
        at Object.Module._extensions..node (module.js:583:18)
        at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:173:20)
        at Module.load (module.js:473:32)
        at tryModuleLoad (module.js:432:12)
        at Function.Module._load (module.js:424:3)
        at Module.require (module.js:483:17)
        at require (internal/module.js:20:19)
        at bindings (/home/pi/MagicMirror/modules/MMM-Buttons/node_modules/bindings/bindings.js:76:44)
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Launching application.
    
    


  • @Blackmirror try to got to cd /home/pi/MagicMirror/modules/MMM-Buttons and run npm rebuild



  • Okay. after npm rebuild the Mirror is still black.



  • I updated to V2.2.1 on my RPI2: no problem.
    Calendar entries work better now.
    Thanks for the work!
    Peter



  • My suggestion would be to back your modules and your working config.js and delete MM and install the new version… That’s the quickest and easiest way



  • I had to do a complete reinstall. Used a backed up sd card and the same error kept appearing in the logs. Backed up all my configs and mods. Did a fresh install and all works fine. Could have been one of the modules that gave it an error, I do not know but the calendar works great now.
    Thanks
    carltonb



  • @carltonb Well sometimes things get ‘lost’ or don’t install properly…so at times things can go wrong and cannot be fixed so that was the best answer. Glad you got it working!!


  • Module Developer

    A quick way to fix this:

    cd modules/MMM-Buttons
    npm install electron-rebuild
    ./node_modules/.bin/electron-rebuild
    

    It always worked for me…