@wuermchen
Hi.
I guess it SHOULD work - at least it works for me at current github status (approx. 2-3 old - not sure what you have archived).
At my own initial setup I got the same error message and after some researches it was caused by refused authentication on the fritzbox side.
So I would start at this point initially - not at module side.
My first attempt was login without password (as possible for console) - this doesn’t work.
I’ve created a separate user on AVM side with full access to phonebook and so on and this worked from scratch.
I see that you have an explicite user/pw as well - so I would double check if this user exists on AVM side and do have the right access privileges.
For being sure I would recommend to delete all parameters from configuration you do not really need and experiment with the base parameters.
E.g. you have set the Port number - at default - I would delete this one.
I’m not sure if you are aware but you can find the documentation of the module in your module folder as well - you do not need the - closed - github entry.
“README.md” is the file.
Good luck!
Ralf