MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

[MMM-Remote-Control] Can not access remote control module



  • @Mykle1,

    thanks 😃

    call me dumb hahahahahahaha

    Unfortunately the modules are not loading now.

    But whats interesting is that if your Ip adress is like “12.10.0.xxx”, the module won’t accept it. If you give your devices a new static IP adress like “12.10.0.xx” then the module works fine. But shows a black screen.



  • I cannot get this to work also…I have added my PC and my phone to the white list, but both say it refused to connect. My “var config” is set to “localhost”…do I need to change that to something else…I am not sure what that part is asking for.





  • @Mykle1 amazing, thanks!



  • @cruunnerr Thank you…it works now.



  • hmmm stuck. I get the create a config screen Heres what I have

    var config = {
    	address: "0.0.0.0", // Address to listen on, can be:
    	                      // - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    	                      // - another specific IPv4/6 to listen on a specific interface
    	                      // - "", "0.0.0.0", "::" to listen on any interface
    	                      // Default, when address config is left out, is "localhost"
    	port: 8080,
    	ipWhitelist: [], // Set [] to allow all IP addresses
    	                                                       // or add a specific IPv4 of 192.168.1.5 :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    	                                                       // or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    	                                                       // ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    

    then on my config

    		 {
    	        module: 'MMM-Remote-Control'
    	        // uncomment the following line to show the URL of the remote control on the mirror
    	        // , position: 'bottom_left'
    	        // you can hide this module afterwards from the remote control itself
    	        config: {
    	            apiKey: ''
    	        }
        },
    

    thanks for helping the clueless rookie



  • you have mm listening on all adapters 0.0.0.0 which correct but the 2[] brackets of your ip whitelist the other side is completely empty.

    What is your routers address? Usually its something like 192.168.1.1 if it was that then 192.168.1.0/24 would allow any local ip to access connected internally on your network



  • @stuartiannaylor tried adding my router info but not successful



  • yeah but you have wiped what there before have a look at :-
    ```
    (3) For security reasons, the MagicMirror (and therefore the Remote Control) is not reachable externally. To change this, configure address, and ipWhitelist in your config.js (see these lines in the sample config). For example change address to 0.0.0.0 and add two allowed devices with IP-Adresses 192.168.0.42 and 192.168.0.50:

    address : '0.0.0.0',
    port: 8080,
    ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.0.42", "::ffff:192.168.0.50"],"
    

    You can also add multiple devices in an IP range (e.g. all devices with 192.168.0.X):

    ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.0.1/120", "192.168.0.1/24"],
    
    
    Have a look at config.js.sample to get the originals back.
    
    Then as it is above your router ip address might be 192.168.1.1 so it would be the above but with ::ffff:192.168.1.42, ::ffff:192.168.1.50  you can also put your router address in there but make the last octal 0/24 and you can then access from your desktop.
    
    Then the next big thing you are missing is apiKey: "",         // Optional, See API/README.md for details


  • @cruunnerr said in [MMM-Remote-Control] Can not access remote control module:

    @budwha

    do it like Mykle said

    https://forum.magicmirror.builders/topic/1517/mmm-remote-control-can-not-access-remote-control-module/18

    I think I have yet I still am getting config screen.

    var config = {
    	address: "0.0.0.0",
    	ipWhitelist: [], 
    
    	language: "en",
    	timeFormat: 12,
    	units: "imperial",
    
    {
    		    module: 'MMM-Remote-Control'
    		    // uncomment the following line to show the URL of the remote control on the mirror
    		    , position: 'bottom_left'
    		    // you can hide this module afterwards from the remote control itself
    		    config: {
    		        customCommand: {},  // Optional, See "Using Custom Commands" below
    		        customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
    		        showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    		        apiKey: "",         // Optional, See API/README.md for details
    		    }
    		},
    
    

    I also watched this and at 4:41 seem to have exactly the same thing.

    https://www.youtube.com/watch?v=539zmAJREe4