Email



  • @Mykle1 I have moved it to module but it is not working



  • This post is deleted!


  • When I wrote the command npm install
    it showed error no License and no repository field found
    then I added repository and license
    but it shows that email@0.0.1 is not valid license spdx expression
    “license” : {
    “type” : “MIT”
    }



  • I’m still having trouble.

    I believe I setup everything correctly. Added the subjectlength at the end, allowed IMAP in my gmail account, but still, after loading the module won’t connect to my mail and doesn’t show anything. Is anyone else having trouble with this?


  • Module Developer

    @umairshah
    If you add a module to the default folder, you have to make the necessary changes to the default.js file to include it.

    It’s just better to put it in the modules folder.



  • @justjim1220 said in Email:

    ou add a module to the default folder, you have to make the necessary changes to the default.js file to inc

    @justjim
    It is not in default folder, it is in the module folder.
    when I download and tried to install it gave error of no repository and license field in package.json, but when I add those fields in package.json then it showed spdx expression error.


  • Module Developer

    @umairshah
    @ime90

    Can you show your config.js file here?

    Make sure you hide personal info…



  • @justjim1220

    var config = {
    address: “localhost”,
    port: 8080,
    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”],

    language: "en",
    timeFormat: 24,
    units: "metric",
    
    modules: [
    	{
    		module: "alert",
    	},
    
    	{
    		module: 'email',
                    position: 'bottom_left',
                    header: 'Email',
                    config: {
                        accounts: [
                            
                            {
                                user: '**@gmail.com',
                                password: '**',
                                host: 'imap.gmail.com',
                                port: 993,
                                tls: true,
                                authTimeout: 10000,
                                numberOfEmails: 2,
                            }
                        ],
                        fade: true,
                        maxCharacters: 30,
    		    subjectLength: 50
                    }
    	},
    
    	{
    		module: "updatenotification",
    		position: "top_bar"
    	},
    	{
    		module: "clock",
    		position: "top_left"
    	},
    	{
    		module: "calendar",
    		header: "US Holidays",
    		position: "top_left",
    		config: {
    			calendars: [
    				{
    					symbol: "calendar-check-o ",
    					url: "webcal://www.calendarlabs.com/templates/ical/US-Holidays.ics"
    				}
    			]
    		}
    	},
    	{
    		module: "compliments",
    		position: "lower_third"
    	},
    	{
    		module: "currentweather",
    		position: "top_right",
    		config: {
    			location: "New York",
    			locationID: "",  //ID from http://www.openweathermap.org/help/city_list.txt
    			appid: "YOUR_OPENWEATHER_API_KEY"
    		}
    	},
    	{
    		module: "weatherforecast",
    		position: "top_right",
    		header: "Weather Forecast",
    		config: {
    			location: "New York",
    			locationID: "5128581",  //ID from http://www.openweathermap.org/help/city_list.txt
    			appid: "YOUR_OPENWEATHER_API_KEY"
    		}
    	},
    	{
    		module: "newsfeed",
    		position: "bottom_bar",
    		config: {
    			feeds: [
    				{
    					title: "New York Times",
    					url: "http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    				}
    			],
    			showSourceTitle: true,
    			showPublishDate: true
    		}
    	},
    ]
    

    };

    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {module.exports = config;}


  • Module Developer

    @ime90

    Try changing the fade to false.

    Make sure your email address and password are case correct (uppercase and lowercase).

    Other than that, I don’t see an issue with the syntax.

    You did change the config.js.sample to config.js, correct?


  • Module Developer

    @ime90

    Also…

    I have found that some modules don’t work as well with the single quotes (’ ').

    Try changing them all to the double quotes (" ")