MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

{HowTo} turn on/off your monitor (Time based, PIR/Button, App)



  • Most modern monitors also have a PowerSave function that completely turn off the monitor when there is no HDMI signal, after a set amount of time. So I guess experimentation will be needed as to what really happen after you have turned it off using either:

    1. vcgencmd display_power 0
    2. sudo tvservice -o
    3. DISPLAY=:0 xset dpms force off (Notice, it’s not necessary to export!)
    4. xset -display :0 dpms force off

    The first 2 turn off HDMI and most likely put your monitor into PowerSave mode, eventually.
    The last 2 only blanks the screen (visible when dark), and does not disable HDMI signals.



  • @E3V3A Some monitors, but almost all television displays turn off after delay (and then cannot be woken in software).

    That, and some folks have complained that they can’t hear a podcast or Alexa because their integrated speakers turn off when the monitor is in powersaving.

    You’re right, it takes some experimentation to tailor to a given use case/situation depending on requirements.



  • I would like to use the MMM-PIR-sensor module to trigger the relay to power off the LCD. However, whenever I set
    relayPIN: 27, in the config.js, the motion detector doesn’t do anything anymore. Anyone know what else I have to change in the config? It’s working just fine without the relay.

    Config working without relay (switches off HDMI):

                    {
                    module: 'MMM-PIR-Sensor',
                    config: {
                            sensorPIN: 22, 
                            relayPIN: false,
                            powerSaving: true,
                            }
                    },
    

    Not working with relay:

                    {
                    module: 'MMM-PIR-Sensor',
                    config: {
                            sensorPIN: 22,
                            relayPIN: 27,
                            relayOnState: 1,
                            powerSaving: true,
                            }
                    },
    

    The problem is I am using a V59 LCD controller board which doesn’t power on again once the HDMI is re-activated.



    1. Can u turn on GPIO27 with gpio -g write 27 1 and off with gpio -g write 27 0 ?
    2. Have u tried just to connect a LED on GPIO27 ?
    3. What relay do u use and how exactly is it connected? ?


  • Hmm, I get

    Unable to determine hardware version. I see: Hardware   : BCM2835
    ,
     - expecting BCM2708 or BCM2709. Please report this to projects@drogon.net
    

    when I run gpio -g write 27 1.



  • @MadScientist said in {HowTo} turn on/off your monitor (Time based, PIR/Button, App):

    Unable to determine hardware version. I see: Hardware : BCM2835

    Huh… a quick google search tells, that this could be several causes. Some wrote to update or downgrade the kernel., some wrote to update wiring pi and so on.
    So its not a problem of the module at all. I’m sorry but for the first u should try to google.

    Maybe start with this: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=182191

    However you should start a new thread if you cannot get to target 😞



  • @MadScientist said in {HowTo} turn on/off your monitor (Time based, PIR/Button, App):

    Hmm, I get

    Unable to determine hardware version. I see: Hardware   : BCM2835
    ,
     - expecting BCM2708 or BCM2709. Please report this to projects@drogon.net
    

    when I run gpio -g write 27 1.

    I had the same issue. I just followed the instructions on the wiring pi site to install. Don’t have my notes but there was a different version depending if you use wiringpi or wiring-pi. I’ll see if I can find the right one.



  • So I think as wiring-pi is the npm specific version the reason it didn’t work was because they haven’t compiled it to work with the pi3 chip.

    Try http://wiringpi.com/download-and-install/



  • Thanks so far. I did npm uninstall wiring-pi and installed wiringpi via git. Now I don’t get the error anymore but the relay still does nothing. It’s getting late and won’t have the time today anymore to look into it. Let me know if you have other ideas and I will continue tomorrow.

    Thanks so far.



  • I think I kept the npm wiring-pi on there as well… There’s probably some other stuff in there that makes it work in mm.